Nissan Forum banner

21 - 33 of 33 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #21
Ill check my knock sensor when it gets warmer out, along with the MAF. If I had enough carbon buildup to cause detonation I would think that my compression numbers would be high, but I was considering cleaning it out with water.
 

·
Registered
Joined
·
316 Posts
A compression test will not indicate I high static (ie 11:1) type of compression. One is in PSI the other is a formula based on the bore/stroke and compression chamber volume.
 

·
neutral handling is cool
Joined
·
180 Posts
If your compression check test normal than you don't have enough buildup to worry about(this is what I have been told). Build-ups aren't good, but they are only really bad when they keep a valve from sealing or affect the spark.
 

·
Registered
Joined
·
118 Posts
mike how does your car feel? like sotp? have you got a chance to drive or ride in anyone else sr20?
im thinking that since dyno's are relative the dyno machine could just be giving you low numbers to begin with. Have you tried a different dyno spot?
cuz it sounds like you fixed alot
 

·
Registered
Joined
·
4 Posts
I figured I'd chime in here. I have the same power problem as Mike (I think.) I have a 1993 Nissan NX 2000 with 203,000 miles, HS intake, HS headers, 4 set UR pullies, and a catco cat. I recently pulled the following numbers on the dyno: 127.1hp, 117.1tq. My lines were also very shaky looking on the chart. I have gotten new OEM plugs, wires, cap and rotor, fuel filter and pcv valve, and installed a brand new OEM clutch and resurfaced flywheel. Compression checks out @ 170 across all 4. Also have a regrounded MAF. I don't know what could be wrong. I recently installed fuel injectors the other day from a JDM sr20, but I'm not sure if that fixed the problem. My butt dyno isn't very fine-tuned. :D The car does feel a little smoother, but only the dyno will tell.

What could cause detonation? BTW, my timing is at 15* and advancing it only made me lose power. My exhaust does have a hole in it, near the axle-back section, but I don't think that matters too much. It's a small hole, anyway.

I have replaced so much, I feel I am running out of options. My dad, who is a muscle car enthusiast, swears that my cams are worn. Perhaps I will purchase used cams. Anyone got any in good condition? Do I need to install new rocker arms with new cams?
 

·
Registered
Joined
·
154 Posts
Discussion Starter #26
no you dont need to install new rocker arms. You might pay alot (100 bucks or so) for the cams though since thats a pretty popular mod for new model sr20's.
 
Q

·
Guest
Joined
·
0 Posts
you have a bad cat......

mpg9999 said:
Like I said I did visually check it, but im still not sure about it. I barely passed emissions (by one point, hehe), and I can smell a sulfur smell if I get on it really hard. Thats why I plan on doing a dyno run with no cat. Get those ideas coming!!!!
-Mike
Replace your cat, here were my results before and after:

My SE-R was labeled a Gross Polluter in CA. My HC's 166, the max 127, my NOx 2147 max 970.

After the second time, I passed CA Smog!!!!WOW!!!

My HC's 54, the max 127, my NOx 236, max 970
It's amazing what a new cat can do to emissons.

So if I was you, replace your cat. I notice a great differance in power. I replaced my stock muffler with a Magnaflow free flowing muffler. Good luck and keep us informed.
 
E

·
Guest
Joined
·
0 Posts
If I install a filter to my car, I have to get the adaptor also right.....

so my question is that if it would be better If i put the whole intake system, o r should I leave the rubber pipe it has and just put the filter with the adaptor???

(I want the best performance, but thats worth the money)
 

·
No Nissan Yet
Joined
·
139 Posts
mpg9999 said:
I have posted this on another board before, but I figured id post it here to see if you guys have any ideas.

My car is not making the power it should. A stock SE-R should put around 120 hp to the ground. The first dyno run I did I had an AEM CAI, and put down about 111 hp. The dyno run is here: http://community.webshots.com/photo...80439XOjVaMGpcI . Notice the line is very shaky. The next time I went I had the AEM CAI, a Hotshot header, and courtesy midpipe (2.5 inch mandrel bent exhaust). I dynoed at around 122-123 hp with that, still very low. In an attempt to fix this problem, I have replaced my dist cap, rotor, plugs (gapped correctly), wires, fuel filter, cleaned air filter, new O2 sensor. I have also reground my MAF, adjusted my TPS voltage. My compression checks out great. My cat is not clogged. My timing is at 15 degrees. Now, here is what I think it could be. The first thing im going to do is have my fuel injectors cleaned and flow tested. I havnt really heard of anyone's injectors getting clogged, but I completely cloged up a fuel filter after less then 5k miles, so thats first on my list. Next up will be some dyno tuning. I am still runing the stock muffler, so I will do a run with no muffler. After that ill do a run with no cat just to make sure thats ok. Then I might play around with my timing some, and also run with the AF ratio probe to see if that tells me anything. If my AF is off, i may replace the FPR (fuel pump has been replaced). Im also going to pull the valve cover and check to make sure my cams are not worn. Anyone have any insights or ideas? TIA

-Mike
I think your are too big on the exhaust. go 2.25. Stock muffler is not what is holding you back per say. Friend went with a 2.25" Universal muffler. Has Hotshot, Cat and 2.25 all the way back. Breates easier, but still has backpressure. Also, what do you mean you "reground" the MAF?

Not all Se-R's put 120 to the ground. Every car is different. How many miles are on your engine?
 
0

·
Guest
Joined
·
0 Posts
mpg9999 said:
My car is not making the power it should. A stock SE-R should put around 120 hp to the ground. The first dyno run I did I had an AEM CAI, and put down about 111 hp.
Check your MAF itself. I fried mine a few months ago and the car dyno'd at 130 when it should've dyno'd ~150 (it had previously dyno'd at 148 and I was trying to hit 150 with some small tweaks that day) Turned out that the MAF had gone bad.
 
0

·
Guest
Joined
·
0 Posts
AztecIam said:
ALMERA,

I must see that dyno chart. Do you have it handy? It is a matter of extreme importance! Please email the chart to [email protected] - thank you!!
Honestly I was so extremely pissed off (because the car had just been giving me problems after problems after problems) that I just got the car off the dyno, packed up my stuff, didn't even say goodbye to any friends and drove 4 hours home. I was PISSED! I can try to see if the shop has it recorded (I doubt they'd hold onto a dyno chart of a 200 with full bolt-ons putting down 130 to the wheels!) but is there anything in particular you're looking for?
 
21 - 33 of 33 Posts
Top