Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have a 93 240sx fastback and for some reason the power antenna mast won't install. I have already looked at 240sx.org and even have the factory service manual and none of them help. I put mast in w/ gears towards motor, turn on radio, and mast goes down but it stops with about 6 inches left. I turn radio on and off quickly and the 6 inches still remain. Anybody got any ideas what i'm doing wrong? BTW mast is genuine OEM from dealer so its not that.
 

·
Tarmac Terrorist
Joined
·
272 Posts
Shift_240 said:
I have a 93 240sx fastback and for some reason the power antenna mast won't install. I have already looked at 240sx.org and even have the factory service manual and none of them help. I put mast in w/ gears towards motor, turn on radio, and mast goes down but it stops with about 6 inches left. I turn radio on and off quickly and the 6 inches still remain. Anybody got any ideas what i'm doing wrong? BTW mast is genuine OEM from dealer so its not that.
I hear people have alot of problems with the power antenas, that's why i replaced mine with a whip antenna.
But then I said screw it, I don't listen to the radio anyway, so I chopped the antenna and body filled the hole, nice smooth and clean now! Good Luck with yours though! :thumbup:
 

·
Registered
Joined
·
34 Posts
u got a faulty antenna. this is common for s13's. mine is the same way but on mine u only hear the motor workin and the antenna doesnt work. just stays 6 inches in the air or so. this is wat was suggested to me. when its all the way out wipe it off really good with some wd40. make sure u wipe off all the wd40 so that dirt doesnt get stuck to it. good luck.
 

·
Sup Mod keeping the peace
Joined
·
7,519 Posts
Shift_240 said:
I have a 93 240sx fastback and for some reason the power antenna mast won't install. I have already looked at 240sx.org and even have the factory service manual and none of them help. I put mast in w/ gears towards motor, turn on radio, and mast goes down but it stops with about 6 inches left. I turn radio on and off quickly and the 6 inches still remain. Anybody got any ideas what i'm doing wrong? BTW mast is genuine OEM from dealer so its not that.
I've done these antenna installs several times. The radio is turned on to remove the antenna and turned off to install the antenna.
Here's a picture
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
That's what I did but it still left six inches out. Maybe it is because I don't know how to turn the motor off like it says in #3 and lower the antenna base. Rogoman could you give me a more detailed instruction and maybe I could figure out what I'm doing wrong from that. Thanks!
 

·
Registered
Joined
·
7 Posts
My antenna on my 90 240 is completely shot and I found one at a local junkyard for $15 but the problem is that everyone says to turn the radio on for it to go down correct? Well this is a junk yard car and it was a PITA getting my stock antenna off but i have to push the antenna all the way down and probably runied it. Anyone have any ideas if the antenna is stuck up all the way? Thanks
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
You gotta force it down. If the mast is broken it won't matter anyway. I had the same problem with mine. I'm just having trouble now installing the new mast. :(
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Irving18m said:
My antenna on my 90 240 is completely shot and I found one at a local junkyard for $15 but the problem is that everyone says to turn the radio on for it to go down correct? Well this is a junk yard car and it was a PITA getting my stock antenna off but i have to push the antenna all the way down and probably runied it. Anyone have any ideas if the antenna is stuck up all the way? Thanks
Oh and I forgot to mention, if your mast is stuck all the way up, it either means the plastic tail of the mast is broken or the motor is busted. In either case the motor has to come out, and I can tell you from experience that removing the motor from the fastback is an enormous PITA.
 

·
Sup Mod keeping the peace
Joined
·
7,519 Posts
Shift_240 said:
That's what I did but it still left six inches out. Maybe it is because I don't know how to turn the motor off like it says in #3 and lower the antenna base. Rogoman could you give me a more detailed instruction and maybe I could figure out what I'm doing wrong from that. Thanks!
To turn the antenna motor off, just turn off the ignition switch. Now push the mast down into the mast pipe by hand as far as you can; put the antenna base on and screw the nut down; now fully raise and fully lower the antenna several times by operating the radio on/off switch. This should fix your problem.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
I decided to give up on trying to fix the power antenna. Can anybody tell me what I need to swap it with a normal antenna?
 

·
Registered
Joined
·
189 Posts
You can buy a normal one anywhere. And they should just fill that spot like the motorized one did. If I was you though look for a Euro style one that is about half or 1/3 the size and are usaully rubber. They look cleaner.
 
1 - 12 of 12 Posts
Top