Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
i recently purchased a set of dropzone lowering springs and installed them on my 95 altima. soon after i noticed a popping noise coming from my drivers side front strut. this is the only place the noise is coming from. i hope its as simple as my splash gaurds hitting my springs and deflecting back, but i fear it is more complicated than that. i have dropped it two inches on factory struts. please, if anyone has any clues as to what this noise is all about, please let me know. thank you muchly.

also i have noticed upon brakeing at fast speeds, my car shakes like a sun-uv-uh-beach. any ideas?
 

·
Mofo
Joined
·
2,225 Posts
Well I installed lowering spring in my old sentra, I had the same problem for about 2 weeks. Then the springs settled and didnt pop ever again. That was about 4 years until I baught some good suspension.
So I take it you have had them on there for about a week right?
Did the shaking just start after you installed the springs? Cause im really thinking you might have a warped rotor. I would suggest having you rotors resurfaced. just take them off and take them down to one of your local brake shops, or a parts store that can do it. Its only about 10-20 per rotor.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
hey nismo guys. great news on the spring popping. it was my inner fender (splash guards) popping against my strut. i just took them out and it rides better than ever. still a vibration upon stopping though. been that way science i got the car. i think it is the rotor, which i suspected it to be from the beginning. holla back,


Big James
 
1 - 3 of 3 Posts
Top