Nissan Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
about three ddays ago i noticed my brake light was on, on my dashboard.. i have a 95 altima gxe auto. so the only time my brake lgiht came on is if i had my e-brake on, but as soon as i put it lever down the light went away. please help why is it staying on all the time. do the pads need changing or are the back brakes connected with the parking brake, i have disc brakes. on all 4!!! please please please helpppp...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
well the fluid is fine, and i just replaced the front and back brakes about 5 months ago, what i am wondering is how is the e-brake set up, is it set up where the back brakes are part of the e-brake system or is it a whole different set pads or something???
 

·
Registered
Joined
·
189 Posts
well the fluid is fine, and i just replaced the front and back brakes about 5 months ago, what i am wondering is how is the e-brake set up, is it set up where the back brakes are part of the e-brake system or is it a whole different set pads or something???
The parking brake lever when pulled makes the rear brakes go on to hold the car. I'd check to make sure the parking brake lever is going down all the way.

I was going to mention the brake fluid reservoir also. It could be the sensor for the brake fluid level is bad.
 

·
Registered
Joined
·
258 Posts
I have 99 sentra gxe and i had the same thing but to be honest i dint pay much attention and one day i took my car to change the oil. it went away after i got the oil change.... im not sayin it will work with you im just sayin it was the wierdest thing i have ever seen....
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top