Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi. My GA16DE 92 makes this Knocking noise once it reaches normal working temperature. I've check the timing and it is ok 10º. I'm using 90 octanes fuel and even when i use 95 octanes fuel, it starts to knock after running for 30 min. When the engine is cold o has not reach the normal operation temperature, it doesn't make any knocking noise. Any idea what the problem could be please?
 

·
Registered
Joined
·
485 Posts
Well im new to these engines and cars, but I would say the ECU would prob go into limp mode for any of the major sensors went out. So I would say check the fuel filter, fuel pump, and fuel pressure regulator. If you are running lean those would be a place to start. You should look at the O2 sensor at the same time. I'm not sure how to test them but I believe there is a way. Oh and please anyone else with ideas please help out or add anything I missed.
 

·
Registered
Joined
·
4,212 Posts
this could be a mechanical problem, maybe a rod bearing. Listen with a long screw driver and open the throttle in short burst. if the knocking is in area of one cylinder and doesn't do this cold only hot when Oil is thin then this is a possibility.
Try adding an octane booster, this would rule out a the normal engine pre-ignition.
Sorry this is all I can think of to add to the above suggestions. Good Luck......
 

·
Registered
Joined
·
322 Posts
I have this problem since day one I owned my sentra.Last for 4 years and put almost 100k miles.Kind of annoying but works ok.All kinds of tune up does not solve the problem.
But now it is getting worse...Time to get another engine...
 

·
Sup Mod keeping the peace
Joined
·
7,033 Posts
Several possibilities:
- Make sure the oil level is at the full mark.
- If the noise has a metallic sound to it, then it could be a worn rod/main bearing.
- The oil pressure may be abnormally low. Check it by using a temporary pressure gauge.
 

·
Registered
Joined
·
4,212 Posts
Good suggestions.
Well 100K miles, I don't think its a rod bearing!!
Are you hearing the valve lash clatter ?
GA's don't have hydraulic lifters, shim adjustment.
I would check the valve clearances next.
It should be easy to rule out detonation with octane booster.
 

·
Registered
Joined
·
322 Posts
It happens usually if I push the engine harder or it's uphill.Does not have any pinging when it's idling.
Yes actually first I thought it was spark knock,so maybe the timing was retarded.Set the timing right but still got this noise.I always run with full engine oil.
I start to suspect either timing chain guides/tensioners go bad or worn bearings.But anyone of this things will just make me change the engine.This engine is like 230k miles and just not worth putting more money in it unless I have the money to rebuild the whole thing.I have done all kinds of tune up but the noise is still there.Worn engine is the only possibilty I can think of.
The pinging gets worse when it's hot,especially in summer.
 

·
Sup Mod keeping the peace
Joined
·
7,033 Posts
Probably carbon buildup in the combustion chambers is causing pre-ignition.
 

·
Registered
Joined
·
86 Posts
Complete fuel system cleaner might help because it's supposed to clean fuel system and also vents and combustion chamber. In finland we have for repair shops professional use liquid called forte fuel system cleaner. It's quite like the best available on the market. Try that and hopefully it removes some carbon buildups. Assumpting that knocking is because pre-detonation.

- No-Pain -
 

·
Registered
Joined
·
1 Posts
Good suggestions.
Well 100K miles, I don't think its a rod bearing!!
Are you hearing the valve lash clatter ?
GA's don't have hydraulic lifters, shim adjustment.
I would check the valve clearances next.
It should be easy to rule out detonation with octane booster.

Hi, I apologize for coming in to this thread so late. I am having almost the same situation as the person how started this thread with a 1994 Sentra GA16DE. The difference may be that I am in Panama and we always have hot weather. I was wondering if you could illustrate me on the Items you mention e.g. Valve lash clatter, Shim adjustment, etc.
Please help in anyway possible.
 

·
Registered
Joined
·
4,212 Posts
download the Factory service manual its free at phatg20.net
I think the engine above with 230K miles needs new chains and at that mileage maybe not worth it as low mileage replacements are relatively in-expensive.
Check your timing and try if its still making noise add Octane booster. it it doesn't stop its not detonation. We have knocksensors anyway, so i don't think the engine will knock due to pre-ignition.
Your first suspect should be the upper timing chain tensioner and guides if you are above 120K miles ( not Km) they seem to go bad, your mileage will vary!!
 

·
Registered
Joined
·
3 Posts
andy

:(
Hi. My GA16DE 92 makes this Knocking noise once it reaches normal working temperature. I've check the timing and it is ok 10º. I'm using 90 octanes fuel and even when i use 95 octanes fuel, it starts to knock after running for 30 min. When the engine is cold o has not reach the normal operation temperature, it doesn't make any knocking noise. Any idea what the problem could be please?
its usually the radiator blocked at the bottom.hence engine not cooling down quick enough.at the bottom half.i had the same prob.changed the rad off ebay for about 45 quid.and no more pinking.if anythink.its sounds more retarded.but more power.and no more pinking under preasure.essepcially uphill.
 
1 - 12 of 12 Posts
Top