Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have already replaced the solenoid valve on the engine and the canister vent valve and I am still getting a P0443 code!

I cleared the codes, did a test drive and the 0443 came back when I started this morning.

The hoses look good at the front and rear.

The solenoid is getting 12+ on one side and about 0.05 on the other.
I do not believe this would qualify as a short? This is if I test to the frame or to the battery negative.

The new solenoid was closed when new and now is in the open position when off the car allowing air to pass.

My gross leak code seemed to go away once I did the canister vent valve.
During the process I have seen 0443 - 0445 and 0447.

0447 when I drove with the vent valve connection off.





The car was a car that sat for a long time - salvage title.
After I bought it I had the ECM replaced and the throttle body replaced.

The car passed emission in 2014 and has been reliable ever since.
The engine light has been on for a long time and now I cannot pass emission.
 

·
Registered
Joined
·
49 Posts
"The solenoid is getting 12+ on one side and about 0.05 on the other. "
Believe that the solenoid is energized when ECM provides ground during purge operation.
A constant .05v indicates that solenoid coil is open or circuit to the ECM or ECM itself is grounded causing error p0443.

If solenoid is constantly energized and denergizes when unplugged then suspect circuit/ECM

Best to verify circuit from electrical diagram.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The issues returned shortly after having a shop fix it (I will list their invoice here soon)
I have the following codes P0443,444, 138 and 139 now. I assume some of those are related to the others.

Where can I begin troubleshooting this again myself?
 
1 - 3 of 3 Posts
Top