Nissan Forum banner

1 - 20 of 66 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
for the past few days i've been trying to figure out why my overdrive has not been working. i finally got my truck on the road after being my project for approx 6wks. i have yet to give it an oil change, and tranny flush n' filter, but other than that it works good. the overdrive light doesn't come on, and the rpm's make no change. i've pulled every fuse in my fuse panel and there was nothing blown. can anyone send me in the right direction? thanks
 

·
Registered
Joined
·
119 Posts
Discussion Starter #3
well, i did the tranny flush and filter, but i've got bigger problems now. i think the truck jumped it's timing lastnight. apparently there are 2 belts for my truck and i don't know which one to get. round tooth or square tooth. i think i'll get both with a haynes and get er' done
 

·
Registered
Joined
·
119 Posts
Discussion Starter #4
did the timing belt, cap and plugs. it has all new fuel lines and filter on it. also put in a k and n air filter in it. the truck still seems to have a slight hesitation when going down the road. i'm not sure where to go from here. i didn't put new wires on it cuz i didn't see any arcing at night so i assumed they were fine.

any sugestions?
 

·
Registered
Joined
·
201 Posts
how many miles? if you haven't done a sea foam treatment do that...took my hez away.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #6
gotcha. there's 249 000 give or take. i'll get a can today. thanks. i'll let ya's all know.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #8
well, i spent all morning searching for info to fix the rest of my "bugs" in my truck. i even bought a haynes manual, and downloaded the pdf file for it. basically i'm down to this: i disconnected my DRL and once i did that my dash lights are extrememly dim. maybe i should hook those back up. i put a new set of headlights in it, and now the driver's side high beam don't work. my overdrive button still aint working. i'll let ya's know my progress today as i'll take my laptop outside with me
 

·
Registered
Joined
·
119 Posts
Discussion Starter #9
figured out my headlight problem, no big deal. found an exhaust leak on the y pipe, so i gotta find one of those. i bought a can of seafoam and put it in the tank. i think the hesitation is still there though. i'll know more tomorrow when i get it up on the highway. also i tore up my console tonight to figure something out with my overdrive switch. there is no power at the switch or conector anywheres. am i missing a fuse or something here? haynes doesn't get into much detail with the overdrive.

thanks
 

·
Registered
Joined
·
201 Posts
i bought a can of seafoam and put it in the tank. i think the hesitation is still there though. i'll k
in the gas tank is fine will do just about as good as b12...now buy another can and run half of that threw the brake booster...clean that carbon up there that the injectors can't get
 

·
Registered
Joined
·
37 Posts
in the gas tank is fine will do just about as good as b12...now buy another can and run half of that threw the brake booster...clean that carbon up there that the injectors can't get
Do you recommend 1/3 in oil 1/3 in gas and 1/3 in brake booster like the can does?
 

·
Registered
Joined
·
201 Posts
slowly feed into brake booster i've seen some cars like up to 2/3 the can. some as little as 1/4. can holds a long time or use in another veh. b12 for gas and and not sticking that in my oil
 

·
Registered
Joined
·
201 Posts
It is best to do it right before a oil change. if you youtube the videos you will get the gen idea how to do it. also not worth doing any less then 30k miles...you will just be wasting your money...but if its never been done 100k plus woo like a god send
 

·
Registered
Joined
·
119 Posts
Discussion Starter #16
i did the seafoam through the brake booster vaccum. it certainly smoked like a trooper. i played with the daytime lights again. i unhooked it because i have a set of fog lights that i use with park lights during the dusk hours. at first i had one high beam out, so i plugged one of the connectors back into the daytime module-and that problem was fixed. however now my dash lights are extremely dim and don't want to get any brighter. so maybe i'm gonna have to plug in that other connector into the drl module to see if that gives me my dash lights back. i had the overdrive plug undone yesterday as well. i can't figure out why it isn't working. there's power in the plug but the light on the dash isn't working, and there is no change in the rpms. is there a hiding fuse somewhere, or is it only that tranny module outfit under the seat that control it?

thanks
 

·
Registered
Joined
·
119 Posts
Discussion Starter #17
i pulled every fuse that i could find, and no luck.

also, i'll be changing my Y pipe within days, is this going to be a PITA job?
 

·
Registered
Joined
·
119 Posts
Discussion Starter #18
got my y pipe changed, well the passenger side pipe anyways. however i'm still at a loss with the overdrive issue, and also, i don't have smooth acceleration. it's not a terrible "miss", but it's noticeable. it's got, new cap, rotor button, plugs, fuel lines, filter. possibly ignition timing?

thanks
 
1 - 20 of 66 Posts
Top