Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'm new to the forum, and new to the z world, but i have a prob i need some help with. I have a 90 300zx n/a, when i turn my headlights on i only have bright lights, no dims, no tails, no corners, no fog, no dash lights, but my dome lights still comes on. I have checked my fuses both under the dash and the hood they're all good. If you have any idea what the prob might be let me know please, i've been trying to fig it out for a week and still no luck. thanks guys.
 

·
Registered
Joined
·
97 Posts
How did you check fuses? By eye or with test light? Check fusible links to if any. barring all that could be your headlight switch.... do highbeam work in normal "on" position or just when you pull back to "flash" position?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
i pulled every fuse out and checked it by eye, i don't know which are which because when i got the car the fuse box cover wasnt on under the dash. I didn't see any fuseable links, and my brights are on when my switch is in the "on" position. that's all i have. someone told me it might be an in-line fuse that's under my dash by my fuse box, the only one i see is a blue wire that's run with a red wire all the way back to the hatch of my car, i believe it's hooked to something to do with my antenna. thats the only in-line fuse i saw, if you know of another one under the dash by my fuse box, let me know and i'll try to find it.
 

·
Registered
Joined
·
97 Posts
ok for starters get a test light and test those fuses. unfortunately check by eye isn't good enough on these cars. i had a similar problem on mine when i got it. lights came on but very dim got sound like super fast turn signal flasher from passenger side under dash, all my idiot lights on (dim) unless i turned on turn signal then lights went out except for the turn signal and buzz stopped no head lights except high beams. Was totally strange. I almost completely disassembled dash hunting for short or bad relay before i got around to using test light on fuses, when i finally got on them with a test light one fuse lit very dim momentarily then burned out put new fuse in and everything has worked perfect since.
 

·
Registered
Joined
·
97 Posts
there should be a fusible link near the battery under hood maybe two, need someone who has tinkered more with the electrical on these cars to tell you that. Do you have FSM yet? if not do a topic search and get one you can download for free. FSM is better than chiltons or Haynes either one.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
alright, i checked my fuses with a test light, and they were all good. I couldnt' find the fusable links by the battery, do you know any way to check the switch to see if it's bad?? some guy said it would've melted on the back if it went out, but mine's fine.
 

·
Registered
Joined
·
97 Posts
should be fairly easy to check open the column and test for power in then test for power out. if you will PM me your email i can send you the wiring schematic for it.
 

·
Registered
Joined
·
13 Posts
should be fairly easy to check open the column and test for power in then test for power out. if you will PM me your email i can send you the wiring schematic for it.
u may want to check some relays for running lights or sumtin around those lines....also check ALL your light(especially the rear lights) for water it may be jus causin a short...alot of nissans are known for water in tail lights n causin that problem as well....so when u tun on your lights does the dash lights come on?

also if u know anyone who need z31 parts i have alot of parts.....make me a resonable offer....u will be surprised. not askin alot $$.....jus need to make some room in my basement.....i have hood, trunk, fenders, headlights n assembly. doors. front & back bumper.. lots of interior peices... all the trim... alll the windows except windshield......spare tire...T-TOPS,,,,windshild washer resevoir....side mirrors....signals..rear lights..rear storage for 2 seater... there may be more but i cant think of anything else..there is most likely more parts. i dont have pictures but the parts are in very good condition WITH NO RUST...mint black turbo seats....colour is black.....take one take all...car is parted, DO NOT HAVE THE CAR ANYMORE...jus parts
 

·
Registered
Joined
·
3,194 Posts
Rulez.. Do happen to have the dash.. Mine us a 86. I don't need the gauges.. Also turn signal swith.. You can email me at [email protected] I live in Southern California thanks
Last Activity: Oct 14th, 2009 10:10 PM
Join Date: Sep 8th, 2009

Chances that "Rulez" will respond?
 

·
Registered
Joined
·
3,194 Posts
1 - 12 of 12 Posts
Top