Nissan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter · #1 ·
Now after i swaped to a UKDM SR20DE (high port) I'am having problems with oil pressure. The engine was disasembled, cleaned and has new rod bearings. The engine is equiped with a oil pressure sender unit.

Now as I start the cold engine the pressure goes up to 4bar. When i rev up the engine it stays there. Now when the engine heat's up the pressure goes down to 1 bar when idling. And when I rev it it goes up to 4bar. That looks ok. But now when i'm driving it happens some times that the pressure goes down to 1bar or less when driving and 0bar when idling (the gauge does not move) but the red light does not come on and the engine runs normal( no ratle from lifters or chai). Now if I turn the engine off and back on again the pressure is normal gain.

The pressure is specified: not less then 0.78bar when idling and not less then 4.5bar at 3000rpm.

What do you guys think? Is the regulator giving me trouble? Now i've changed the sender unit and will see what happens. But when the engine was cold the pressure was 4bar again and when i reved it stuck there...
What else could be wrong? Does anybodie know the pressure when the light comes on?
 

·
Registered
Joined
·
98 Posts
check the sending unit or try getting a new oil presser gauge...... but if everything runs great the only thing i could see wrong is the stuff i said above. just keep an eye on oil levels and see if you have oil leaks, oh yeah check to make sure everything is grounded properly
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #3 ·
That's what i've done today.. Installed another sending unit and welded some extra grounding wire to it to ground it for shure. And checked the gauge, seems OK too. Will try it out tomorrow and see what happens...
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #4 ·
OK back on the street after my radiator was leaking coolant..

With the new oil sender unit it looks litle better now. The pressure is not droping down to 0 anymore but the high pressure is only 3,5bar and that does not look good to me..

The presure at idle engine warm is 1,3bar and then when i rev up the engine it quickly raises and reaches 3,5bar at 2500rpm. Now when I rev it higher it stays at 3,5bar?? I've tested the sender unit with conpressed air and it works OK... Can it be that the spring that is regulating the oil pressure goes week and so the valve opens to soon? The engine has 160000miles on but was rebuild now. I'am using now Valvoline VR1 5W-50...
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #6 ·
The full name is Valivoline VR1 Racing 5W-50. I buy it at my friends repair shop. And he gets it from the Valvoline importer.( I live in the EU)...
 

·
Registered
Joined
·
83 Posts
hey man i don't know what to say about the sending units and all that but what i do know is that when i swaped my ga for an engine like yours my oil pump caused me problems i let it pass by and boom 3 weeks ago dead sr20
just saying watch out for that erratic oil psi bro

just my 2 cents :cheers:
 

·
Registered
Joined
·
151 Posts
As the oil heats up, the pressure will be lower. After a few laps on the track, my oil pressure gauge reads almost 0. It could be an oil pump issue, but it sounds like the oil is warming and cooling. Oil takes longer to warm up, but cools much faster than water.
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #9 ·
But if the oil pump wuld be bad there will be no pressure when the engine is idling. I have 1,5 bar (22psi) at idle and 3,5bar 50psi before 2500rpm but then it stays there. These readings are made at hot engine. When cold the pressure is at 4bars when driving.

I have to say that i have done all the clearance checks on my oil pump and it's all in the tolerances.

I'am suspecting the pressure regulating valve to open to soon. But it's a lot of work to pull it out and check the spring. So I would like to clear this up.

And my **** radiator is leaking again so I'am off street and sick of it.
:wtf: is happening with my ride...
 
1 - 9 of 9 Posts
Top