Nissan Forum banner
1 - 5 of 5 Posts

· Banned
Joined
·
5,533 Posts
Discussion Starter · #1 ·
Well I drive to the post office this morning to attempt to get my shoes, but what do you know they aren't open on any of the weekends.

When I stop no problems, kill the engine and woof I see smoke (in reality it was steam). So in my head I'm cursing like a mofo. I pop the hood and let it escape and I look around on the driver side bank of the engine and I see coolant. So instantly I'm like damn my HG just blew. But me not running over 5 PSI most of the time it couldn't be. So I took a closer look and it was dripping off of the valve cover. I traced the drip as well as I could and I believe my throttle body once the engine is shut off the coolant inside starts boiling. So I drove back home (babied it) stopped turned off the engine and pop the hood. Well then it doesn't happen.

Fluke?

Leaky Hose?

You tell me your best guess.
 

· Banned
Joined
·
5,533 Posts
Discussion Starter · #3 ·
Domdogg123 said:
are you sure it was coolant?
...leaky valve covers?

Yep coolant because it had a green tint and sizzled when it hit the manifold.
 

· Banned
Joined
·
5,533 Posts
Discussion Starter · #5 ·
I found a hose with a bit of brown discoleration on the part where it attaches to the fitting. I tightened it and we'll see how it goes.


Yes it went through but unfortuneatly it took away 69 cents because it was from a debit or credit card;)
 

· Banned
Joined
·
5,533 Posts
Discussion Starter · #6 ·
Well I cranked it up for about 5 minutes this morning and took a quick drive and it did it again. I think I might be ripping the driver side of the engine apart soon :(
 

· Banned
Joined
·
5,533 Posts
Discussion Starter · #10 ·
I plan to fix it right... At stock specs. So looks like I'll be getting another hose.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top