Nissan Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I have a 91 2.4 HB. 241,000 on the clock. I am having a wierd issue with it. When the motor gets to normal operating tempature, if you cut if off it won't restart. It turns over very slowly, almost like it has a weak battey. I thought is might have been the starter, so I replaced it with no luck. I then thought timing was off, checked timing, still no luck. I have cleaned the engine grounds and it has a recent tune-up. Any ideas of what it could be? I'm lost.
 

·
Registered
Joined
·
49 Posts
Alternator maybe? To me it would seem that it would have to be either the starter, battery, or the alternator. And since it is not the first two then maybe the alternator.

I don't know too much about the inner workings of these engines, but I do know that when I had my gas rc trucks if they ran too rich they would lock up with unburnt fuel. I would have to open the throttle all the way and crank it to get that extra fuel out.

I dont know how this applies to 4stroke car engines but just throwing some things out there to get ya thinking. *shrug*
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Alt and battery was tested. Both are good. I was wondering if the valves are adjusted too tight. Are they adjustable in these trucks?
 

·
Registered
Joined
·
153 Posts
That's what my 720 Z24I starting doing,and it's was soon after the fuel pressure regulator started showing worse symptons,before needing replaced-rough idle, and a bad fuel smell in the exhaust.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
I don't think it's a fuel issue. It runs great for the mileage. The only other issue is it misses while idling. It does it at complete random. It averages 21mpg mixed driving. I'm thinking it's in the valvetrain, but I wanted some other thoughts.
 

·
Registered
Joined
·
49 Posts
I don't think it's a fuel issue. It runs great for the mileage. The only other issue is it misses while idling. It does it at complete random. It averages 21mpg mixed driving. I'm thinking it's in the valvetrain, but I wanted some other thoughts.
Distributor maybe? I had a 90 sentra that had almost the same symptoms and I found out my distributor was bad (oil leaked in somehow and screwed it all up)
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
It could be the dizzy. I have also read that the pick up in the dizzy could be bad. I took the cap off today and it looked good. The contacts were still nice and clean. It really bugs me. I have another truck to drive but I'd rather drive the Nissan. It's a fun little truck. I just hate that I can't turn it off if I go somewhere... LOL
 

·
Sup Mod keeping the peace
Joined
·
7,227 Posts
Alt and battery was tested. Both are good. I was wondering if the valves are adjusted too tight. Are they adjustable in these trucks?
I'll assume the motor is a KA24E; if so, hydraulic valve lifters are used which are not adjustable.

Several things to check for hard starting:
- low fuel pressure
- bad fuel pressure regulator
- weak spark
- bad battery
 

·
Registered
Joined
·
3,344 Posts
on the old Max's, Stanza's, etc there was a trig (ignition) unit inside the dist. that would expand when hot and break contact, once it cooled down you could start it again.. might be something similar in your situation
 

·
Registered
Joined
·
41 Posts
fuel and spark should not be causing his problems if i understand him correctly it is turning over very slow which is causing it not to crank
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
fuel and spark should not be causing his problems if i understand him correctly it is turning over very slow which is causing it not to crank
Exactly!! The only way it could be a fuel issue is if it was filling the motor up with fuel. That would hydrolock the motor. It gets good gas mileage, 21 mpg mixed, so we can rule that out. I have checked the fuseable links at the battery, they are good. The best way to descirbe it... It turns over very slowly almost like the battery is dead or the starter is bad. It only does this when the engine is at normal operating tempature. Yes, BTW KA24E.
 

·
Registered
Joined
·
41 Posts
do an amp draw test on the starter cold then hot and let us know i see you changed the grounds check your positive cable for a weak or bad spot yes valves are adjustable small chance it could be it not very likely but posible still could be starter also i have gotten bad ones from store before do amp draw test to see what kind of current you are drawing it is possible something can be stopped up inside causing it to try and seize up let us know the outcome
 

·
Registered
Joined
·
30 Posts
Discussion Starter #15
Ok guys, going off a hunch, I tired something yesterday. Now I have only expierenced this problem when the motor was hot. Now, yesterday I started it up, then I immedately turned it off. I restarted it, it dragged but started. I tried a third time and there the problem was again. It wouldn't start, just turn over slowly. So I took the battery out and had it tested twice. It's bad.


I assume the first time I had the battery and alt tested, they guy doing it didn't do the battery or was to stupid to know how to read the machine. So, I am picking up a battery tomorrow and I wil let you guys know the out come.
 

·
Registered
Joined
·
706 Posts
If it's a 5 speed change that inhibitor relay or stick a wire in the contacts to bypass it! Try it then...
 

·
Registered
Joined
·
13 Posts
You could check the ignition coil. Ive had one failed on me slowly once the car heats up to operating temp. Just my 2 cents....
 
1 - 20 of 27 Posts
Top