Nissan Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have an 07 Nissan Frontier and recently had to change the TCM, after replaceing both the TCM and all the Transmission shift Solenoids I had ended up (cherry on top) Losing the Key. (which is of course chipped). I ended up having a locksmith come out to program a new one (200 bucks on top of the already 220 for TCM and Solenoids) and when he tried to progam the key but the OBD ii Port wouldnt respond. No codes thrown, no message except from his computer that stated that the port wasnt responding. I checked the Fuses and none were Blown. When i Looked under the Dash at the port I seen the extra ports coming off the side of the wiring for the OBD ii port but after a little researching I figured out that at least two of them were for other options that my truck doesnt have. Its the Third port that i Found that bothers me. It looks as if 2 of the wires off the side of the harness that connecting to the OBD ii port have been spliced into and a smaller port is connected to those. I will post Pictures asap, but the third port wasnt connected to anything and I have found no other plug that it might go to anywhere under the Dash.
Gas Electrical wiring Cable Auto part Wire
Gas Electrical wiring Cable Auto part Wire
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
ok, so I may need to unhook the TCM or? Ill admit that I'm not a certified mechanic, (been learning as I go) so the "umbilical" to the transmission is confusing me a little. and how would I go about programing a TCM? or at least checking to see if mine is yet? because even if it is brand new that doesn't mean that its already programmed. is there a way to check the Port for the OBD ii to see if its faulty besides the fuses?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
also is there a way to get a wiring diagram for the OBDii that I can at least understand little lmao Most I have found online I cant understand . and I figure the diagram would help with tracing back wires to make sure they are good
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Ok. So ive got new solenoids on a new Tcm inside the trans now. umbilical is disconected. how would i test the OBD ii to see if its working if i dont have a sensor to plug into it? i have a multimeter but no sensor. I just dont want to call the Locksmith back out to program my key if he cant do it again. -_-
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
ok. so after putting in the new TCM, New Solenoids, New Battery, and replaceing the Trans filter, and fluid. I tried to have a key programmed again, but instead of not finding the port. the port worked. but the BCM cant send the code. Not the New or old Codes. I still need to unplugg the Umbilical for the Trans to see if that is what will help the BCM get its butt in gear but as of right now the BCm not sending the codes is the only thing keeping the Truck from starting. I will keep you guys updated as much as i can. The Locksmith is suppose to be back out in the morning and said that he wanted to call the technical support for the Frontier Transponder keys (or something of that nature). I mentioned the process of unhooking the umbilical for the trans and it potentialy helping fix the issue but he was overly skeptical (which i dont understand because its not like it would have hurt anything anyways) and tried programming the key with little change made since he tried the first time. hopefully unhooking the trans works becuase i cant afford to replace the BCM. I dont have any type of scanner that would help read the OBDii codes. all i have that can test anything even remotely electrical is a 7 function Multi-Meter and a homemade test light lol. so any and all advice given is greatly appreciated.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #15 ·
OK. Tried unhooking the Trans and programing the key. but the same error code is popping up. "error retrieving the codes from the BCM. try unhooking the programmer after the BCM reads but before the codes are sent and hooking the programmer back in." ...I I'm still completely lost. we tried unhooking the Trans and hooking it back in. I checked all the fuses again.. both outside and in. -_- made sure the TCM was properly installed and shift sensors were placed correctly. I don't have a code scanner though. I have a friend coming tomorrow with one that can clear codes. ill keep yall posted on which codes are thrown.
 
1 - 10 of 10 Posts
Top