Nissan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Ok.. I have a serious problem.. i just bought a s13 with a rb25det swap. sounds great right? not so much.. i knew it had a boosting problem when i bought it but my tuner and the guy i bought it from thought it was just a flash thats on my ecu but now that i have it im thinking not.. it makes about 117 comp. and is timed dead on. there is no boost leak and idk what the fuck is wrong? it boggs down like the timing is waaay off untill about 5500 when the turbo STARTS to spool. it takes it untill about 6500 to spool and thus my problem. its making about 350 whp for 1000 rpm but up untill the turbo spools it is slower then a 15 yr old mini van.. anybody got any ideas??

btw the guy i bought the motor from was a retard and did a shitty ass swap.. but i dont know much about rbs so im not sure what to look for.. im hoping its just a dumb mistake made during the swap.. and the guy wont answer his phone for me anymore so i have no background on the car..
 

·
Registered
Joined
·
630 Posts
whats the exhaust smoke look like?

usually if a car boggs down its a fuel problem... so the car could be boosting early but since there is too much fuel it doesnt have the right a/f mixture until higher boost when there is more air...

if your tuner doesnt know how to fix the problem then i suggest you find a different tuner
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
the exhaust is like straight fuel can you take the maf out without problems? i think the maf was unplugged but i didnt think that mattered because im running a piggyback map2 ecu?
 

·
Registered
Joined
·
630 Posts
check your injectors(could be some serious leaking) get them flow tested

im not to familiar with piggyback systems, they seem to be good if they are installed right... but create lots of problems when not...

perhaps the sensors are toasted... and giving faulty readings to the ECU...

where are you located... i knowof a few sites that have more traffic and more knowledgeable people than me...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
ok that sounds possible and what sensors? a couple people told me to cheak my relays too? that would make sense if the injectors were dumping fuel when im at low rpm and the motor just cant feed the turbo.. i think the guy put bigger injectors in but he prolly had no idea what ones to put in.. do you know weather low/high impedence affects it that much? and im in littleton co, just outside of denver
 

·
Registered
Joined
·
630 Posts
hmm ya not too many us sites that ive found where the people actually know what they are talking about...

the sensors would be your maf sensor or your map sensor, but if there are bigger injectors on there chances are you should find some stock RB25 injectors and put them in, i bet that would solve the problem... or at least help somewhat...

but to get some more advice on this come on over to GTRCanada.com lots of helpful people on there, and while it is mostly a skyline site, you have an RB motor so where else would you go for good advice :D just ask for help in the general tech section and im sure a few of the guru's will diagnose your problem :D
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
ok thanks man its just drivin me nuts man this rb should be puttin like 380 down at 5000 and i cant even get 10 pounds by then lol
 

·
Registered
Joined
·
630 Posts
ya the stock injectors will be more than adequate for 350whp, bigger injectors would be needed at the 550hp and up mark
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
any idea where i can get some stock injectors? or maybe make these work? i will go cheak what injectors i have in there now.. im pretty sure there in the 500cc range
 

·
Registered
Joined
·
630 Posts
check out the FS section on gtrcanada im sure you will find what ya need :D either that or contact one of the vendor/sponsor's of the site and they will either have some in stock or be able to get you them ASAP
 
1 - 11 of 11 Posts
Top