Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
hey i need help
my 90 pathfinder had a problem it used to be everytime i start it after about a minute it could barely idle, then it would go away, or when driving i would loose power and not woudnt run good then it would clear up and be fine. now i have no start. my i have to jump my fuel pump through the relay. then it would start or disablle the pump and it would run with the fuel already in the sysem, then before it dies i enable the pump and it would run. it doesnt start when cold but it will start when its at normal operating temp... ahen you first start it up it has a lot of black smoke especially when you rev it up.. also the spark plugs were super black but were dry i suspect before the no start situation i retimed my engine, i switched the ECT, TPS, MAF, ECCS, and the sending unit.. i cant start my truck need help
 

·
Moderator
Joined
·
3,553 Posts
Check relays, the safety relay, inhibit relay and a few others can cause a no-start situation. Have you checked your cap and rotor? Fuel filter? Air filter?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
i just rebuilt the motor, i boredit .20 over, got pacesetter headeers, ive always had a k&n air filter i i cleand and oiled it, i replaced the cap and rotor after the rebuild, i put an oil filter relocation kit, centerforce clutch stage ll.
i checked i have fuel presure and the no. 1 injector is pulsing i assume everything else is injecting, i switched the coil and ignition control, but no change, so i put mine back, i set a scope up and everything looked fine no. 1 firing line was kinda of high but i dont think that cause the problem. my fuses are all good i asume no short circuit, well none high enough to blow a fuse... my fuel pump relay doesnt click so i replaced nothing happened when i send power to the fuel pump my car starts but when i dont it will not, but if i put a relay in right after i jump it it will start once but not a second time...
 

·
Moderator
Joined
·
3,553 Posts
There are several relays in line before the fuel pump relay, IIRC they're the safety relay and the inhibit relay, try messing with those? I think the inhibit relay is under the hood in the block of relays along the pass. side fender.
 
1 - 4 of 4 Posts
Top