Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1994 Nissan Sentra and recently my cruise, speedometer and odometer stopped working. The Check Engine light came on when I drove the car. I have looked for the fuse but couldn't find it, and suggestions? If it's not the fuse what might it be?
 

·
Registered
Joined
·
15 Posts
anreeve said:
I have looked for the fuse but couldn't find it, and suggestions? If it's not the fuse what might it be?
Do you have the owners manuel? it should give the locations for the fuses. If not, try to find the chiltons repair book for it. They are worth their weight in gold.

And it sure sounds like a fuse problem, except the the check engine light comes on. that's an oddity.
 

·
Registered
Joined
·
27 Posts
Go behind the odometer and check the cable, its covered in a square piece of plastic right behind the speedometer. It might be disconnected. Result like you said no speedometer and of course the check light. And later on the car runs like booty. Does the tach work still?

of course check that and the other end where it meets the tranny.

good luck
 

·
Registered
Joined
·
55 Posts
Yeah check the cable. Its really easy to get to where it meets the tranny and it takes about 15 minutes to check it behind the dash (you have to disconnect the one from the tranny so that you have some slack and can pull your gauges out a bit. Just make sure you dont lose the rubber piece where the cable goes through the firewall).
Also you might want to check the vaccum for the cruise control. It is located in the back of the engine compartment and it looks like about the size of half of a soda can and is black and rubber. Follow both hoses as far as they go and make sure that they are hooked up correctly. One of my hoses came out once and I about went nuts trying to find out what went wrong.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
1810 said:
Go behind the odometer and check the cable, its covered in a square piece of plastic right behind the speedometer. It might be disconnected. Result like you said no speedometer and of course the check light. And later on the car runs like booty. Does the tach work still?

of course check that and the other end where it meets the tranny.

good luck
My car doesn't have a tachometer. I had it narrowed down to the cable or the sensor; now it's just a matter of finding someone who can look at it since I don't really have the tools here. Is there any particular reason the cable becomes disconnected?
 
1 - 5 of 5 Posts
Top