Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
The left highbeam in my 94 Sentra is not working most of the time. I've replaced bulbs and even the socket for that light. I checked the wire with my test light and all I got was nothing to a slight glow as I followed the wire back to the right side. At that point the harness disappears under the fuse box so I couldn't follow it further. I searched "sentra headlight" on this site and the best I could find is that the headlight switch may be bad. Has anybody else dealt with this problem? How tuff is it to replace? Where is it? Is there a relay? Is it wired from the switch on the steering column separately for left and right sides? Anybody have a diagram for this car? My local junk yard has a car I can take the switch from if I know where to look.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
I'm gonna reply to myself so that if somebody else searches this topic he will get some help. I found a thread elsewhere on this site, I think it was one of the truck forums, about bad Nissan headlight switches. It suggested taking the switch out and cleaning it with electronic cleaning spray.
In order to get at the switch I removed the plastic covers on the steering collum by loosening the 4 screws on the underside of it. I also found it helpful to remove the plastic panel that is beneath the dashboard. This is also removed with 4 screws. Take the fuse box cover off first. once the covers are off the steering column the headlight, and turnsignal switch can be removed by loosening the 2 screws. The wire harness snaps off. Remove the white plastic cover from the switch and spray the contacts with the cleaner.
This worked for me and only took about 45 minutes. All I needed was a phillips screw driver and a flat head screwdriver to pry the platic covers apart. These are the things I was hoping to find out when I posted in the first place. I hope this is helpful to somebody else in the future.
 
1 - 2 of 2 Posts
Top