Nissan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi All, I want to share my experience of a major fault, that I had with my brand new X-Trail recently.

My vehicle is a 2019 Hybrid model made for the Middle East (I am situated in Jordan).

During driving in the city (heavy traffic), the RED brake light came ON, so was the buzzer. suddenly the YELLOW brake light went ON as well. So I stopped to see what is going on.
I checked brake fluid and brake pedal, they seemed OK. I turned off the engine, pressed the brake couple of times and started again. The YELLOW light went OFF but the RED was ON for a while (also was the buzzer), but after some seconds, it went OFF. I started to drive but soon the RED went ON again and suddenly the brake pedal went rock hard, I had to use both the brake and handbrake to stop the vehicle before running into the bumper of the car in front.
I stopped again and opened the Owner's Manual to read about the symptoms. It mentioned that "...when the RED brake is ON together with the buzzer, the vehicle has to stop and the dealer needs to be contacted..", the YELLOW means that there is a major fault with the regenerative brake system and also the dealer needs to be contacted.

I drove the car to the dealer, after the lights were OFF, but there is a noise now when the brake pedal is depressed. The dealer told me that the brake pump assy (with all the motors and switches/valves) needs to be replaced. They also told me that they experienced a couple of other vehicles with same problem.

I am waiting to know more from them and I will get back with updates.

The frustrating issue is that I have 1635 Km on the clock! I got the vehicle before 20 days!!

If anyone had similar problem, please let me know!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Update:

I have received information from the local dealer regarding the fault code my vehicle had, it is C1111.
By extensive search I made, I found out that it is related to Pump motor.
It has been very confusing to me, as I need to understand the damage.
By first, I cannot find any related document (repair manual) for my vehicle. I need to see the flow of operation between brake pump-abs unit-chassis control.
Secondly, the dealer has told me that he is replacing the whole brake assembly (vacuum-pump). but the fault code is related to ABS unit, or not?

At some stage, the dealer offered me the following: to perform brake fluid replacement and system bleed, and let me use the vehicle until the part to be replaced arrives.
My response was that: '... if you make your talk into writing and assure me that the vehicle is safe to be driven, until you supply and replace the faulty part, I do not mind, by if you are not certain regarding the safety, then I do mind to use it.."
After that, they came back and told me that they will perform some more tests and get back to me the following day.
Next day, I received a call that they have decided to provide me with a rented vehicle to use, until mine is fully repaired.

So now I am waiting patiently (and eagerly at same time) for the part to arrive. Meanwhile, I am trying to find more information in order to understand the problem.
My background is Automotive Engineer and my curiosity needs to be fulfilled.
 

·
Admin and Sup Mod keeping the peace
Joined
·
8,189 Posts
The FSM states the possible causes of the C1111 fault code:

  • - Faulty Anti-Lock Brake System (ABS) Actuator And Electric Unit
  • - ABS Actuator And Electric Unit harness is open or shorted
  • - ABS Actuator And Electric Unit circuit poor electrical connection
  • - Fusible link
  • - Battery power supply system
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
The FSM states the possible causes of the C1111 fault code:

  • - Faulty Anti-Lock Brake System (ABS) Actuator And Electric Unit
  • - ABS Actuator And Electric Unit harness is open or shorted
  • - ABS Actuator And Electric Unit circuit poor electrical connection
  • - Fusible link
  • - Battery power supply system
Thank you rogoman, I guess that this is taken from the repair manual. By reading the possible causes, I can not understand the local dealer's description that the problem lies with the brake pump assembly and especially with the brake pressure accumulator and electric pump unit.
It should not give also a C1142 Pressure sensor fault code?

Does anyone have any schematic of the brake system showing/describing components?
If only I could get a copy of the repair manual....
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
After getting hold of Repair Manual for Nissan Roque Hybrid 2017-2020, and reading the Brake Control System and Brake System accordingly, the Fault code C1111 is also related to Pump Motor. The possible causes are described as follows:
• Harness or connector
• Hydraulic brake booster unit
• Fusible link
• 12V battery power supply circuit
• 12V battery

The dealer's remarks and what actually happened to me on the road, now make sense. For some reason, mostly due to
malfunction of motor, motor relay, accumulator or accumulator pressure sensor, during EV mode and continuous braking conditions in traffic, the system's brake pressure decreased. The RED Brake light came ON due to one of the mentioned reasons and at some stage the brake pedal become hard due to lack of brake pressure.
The reason for the Brake System Warning Lamp (Orange) to come ON at some stage, is mostly because the Control Unit was trying to operate the Pump Unit in order to increase brake pressure, but the pump was not working, or working intermittently with no brake pressure increase.
Taking into consideration all of the above, I would suspect either a pump motor malfunction, a motor relay malfunction, an accumulator pressure release valve that stuck open, and of course, a bad electrical connection to any of these components.

Anyway, I am still waiting for the new Hydraulic Brake Booster Unit to arrive and be replaced on my vehicle.

I hope this helps anyone that might have faced such incident (hopefully no one!!) and mind you that the above applies to the Hybrid model only.
 

·
Registered
Joined
·
1 Posts
Hi All, I want to share my experience of a major fault, that I had with my brand new X-Trail recently.

My vehicle is a 2019 Hybrid model made for the Middle East (I am situated in Jordan).

During driving in the city (heavy traffic), the RED brake light came ON, so was the buzzer. suddenly the YELLOW brake light went ON as well. So I stopped to see what is going on.
I checked brake fluid and brake pedal, they seemed OK. I turned off the engine, pressed the brake couple of times and started again. The YELLOW light went OFF but the RED was ON for a while (also was the buzzer), but after some seconds, it went OFF. I started to drive but soon the RED went ON again and suddenly the brake pedal went rock hard, I had to use both the brake and handbrake to stop the vehicle before running into the bumper of the car in front.
I stopped again and opened the Owner's Manual to read about the symptoms. It mentioned that "...when the RED brake is ON together with the buzzer, the vehicle has to stop and the dealer needs to be contacted..", the YELLOW means that there is a major fault with the regenerative brake system and also the dealer needs to be contacted.

I drove the car to the dealer, after the lights were OFF, but there is a noise now when the brake pedal is depressed. The dealer told me that the brake pump assy (with all the motors and switches/valves) needs to be replaced. They also told me that they experienced a couple of other vehicles with same problem.

I am waiting to know more from them and I will get back with updates.

The frustrating issue is that I have 1635 Km on the clock! I got the vehicle before 20 days!!

If anyone had similar problem, please let me know!
Good morning
Im in Trinidad and have a 2016 hybrid xtrail and experienced this same problem in december..the mechanic serviced the master cylinder but I had reservations and had it parked up..Drove the vehicle yesterday 28th February and the problem came back..My vehicle has 67,000 km on it...Now the mechanic is telling me the accumulator motor has a short..I am so frustrated.
Zalika
 

·
Registered
Joined
·
2 Posts
Hi All, I want to share my experience of a major fault, that I had with my brand new X-Trail recently.

My vehicle is a 2019 Hybrid model made for the Middle East (I am situated in Jordan).

During driving in the city (heavy traffic), the RED brake light came ON, so was the buzzer. suddenly the YELLOW brake light went ON as well. So I stopped to see what is going on.
I checked brake fluid and brake pedal, they seemed OK. I turned off the engine, pressed the brake couple of times and started again. The YELLOW light went OFF but the RED was ON for a while (also was the buzzer), but after some seconds, it went OFF. I started to drive but soon the RED went ON again and suddenly the brake pedal went rock hard, I had to use both the brake and handbrake to stop the vehicle before running into the bumper of the car in front.
I stopped again and opened the Owner's Manual to read about the symptoms. It mentioned that "...when the RED brake is ON together with the buzzer, the vehicle has to stop and the dealer needs to be contacted..", the YELLOW means that there is a major fault with the regenerative brake system and also the dealer needs to be contacted.

I drove the car to the dealer, after the lights were OFF, but there is a noise now when the brake pedal is depressed. The dealer told me that the brake pump assy (with all the motors and switches/valves) needs to be replaced. They also told me that they experienced a couple of other vehicles with same problem.

I am waiting to know more from them and I will get back with updates.

The frustrating issue is that I have 1635 Km on the clock! I got the vehicle before 20 days!!

If anyone had similar problem, please let me know!
 

·
Registered
Joined
·
2 Posts
Hi All, I want to share my experience of a major fault, that I had with my brand new X-Trail recently.

My vehicle is a 2019 Hybrid model made for the Middle East (I am situated in Jordan).

During driving in the city (heavy traffic), the RED brake light came ON, so was the buzzer. suddenly the YELLOW brake light went ON as well. So I stopped to see what is going on.
I checked brake fluid and brake pedal, they seemed OK. I turned off the engine, pressed the brake couple of times and started again. The YELLOW light went OFF but the RED was ON for a while (also was the buzzer), but after some seconds, it went OFF. I started to drive but soon the RED went ON again and suddenly the brake pedal went rock hard, I had to use both the brake and handbrake to stop the vehicle before running into the bumper of the car in front.
I stopped again and opened the Owner's Manual to read about the symptoms. It mentioned that "...when the RED brake is ON together with the buzzer, the vehicle has to stop and the dealer needs to be contacted..", the YELLOW means that there is a major fault with the regenerative brake system and also the dealer needs to be contacted.

I drove the car to the dealer, after the lights were OFF, but there is a noise now when the brake pedal is depressed. The dealer told me that the brake pump assy (with all the motors and switches/valves) needs to be replaced. They also told me that they experienced a couple of other vehicles with same problem.

I am waiting to know more from them and I will get back with updates.

The frustrating issue is that I have 1635 Km on the clock! I got the vehicle before 20 days!!

If anyone had similar problem, please let me know!
Hi All, I want to share my experience of a major fault, that I had with my brand new X-Trail recently.

My vehicle is a 2019 Hybrid model made for the Middle East (I am situated in Jordan).

During driving in the city (heavy traffic), the RED brake light came ON, so was the buzzer. suddenly the YELLOW brake light went ON as well. So I stopped to see what is going on.
I checked brake fluid and brake pedal, they seemed OK. I turned off the engine, pressed the brake couple of times and started again. The YELLOW light went OFF but the RED was ON for a while (also was the buzzer), but after some seconds, it went OFF. I started to drive but soon the RED went ON again and suddenly the brake pedal went rock hard, I had to use both the brake and handbrake to stop the vehicle before running into the bumper of the car in front.
I stopped again and opened the Owner's Manual to read about the symptoms. It mentioned that "...when the RED brake is ON together with the buzzer, the vehicle has to stop and the dealer needs to be contacted..", the YELLOW means that there is a major fault with the regenerative brake system and also the dealer needs to be contacted.

I drove the car to the dealer, after the lights were OFF, but there is a noise now when the brake pedal is depressed. The dealer told me that the brake pump assy (with all the motors and switches/valves) needs to be replaced. They also told me that they experienced a couple of other vehicles with same problem.

I am waiting to know more from them and I will get back with updates.

The frustrating issue is that I have 1635 Km on the clock! I got the vehicle before 20 days!!
 

Attachments

·
Registered
Joined
·
1 Posts
After getting hold of Repair Manual for Nissan Roque Hybrid 2017-2020, and reading the Brake Control System and Brake System accordingly, the Fault code C1111 is also related to Pump Motor. The possible causes are described as follows:
• Harness or connector
• Hydraulic brake booster unit
• Fusible link
• 12V battery power supply circuit
• 12V battery

The dealer's remarks and what actually happened to me on the road, now make sense. For some reason, mostly due to
malfunction of motor, motor relay, accumulator or accumulator pressure sensor, during EV mode and continuous braking conditions in traffic, the system's brake pressure decreased. The RED Brake light came ON due to one of the mentioned reasons and at some stage the brake pedal become hard due to lack of brake pressure.
The reason for the Brake System Warning Lamp (Orange) to come ON at some stage, is mostly because the Control Unit was trying to operate the Pump Unit in order to increase brake pressure, but the pump was not working, or working intermittently with no brake pressure increase.
Taking into consideration all of the above, I would suspect either a pump motor malfunction, a motor relay malfunction, an accumulator pressure release valve that stuck open, and of course, a bad electrical connection to any of these components.

Anyway, I am still waiting for the new Hydraulic Brake Booster Unit to arrive and be replaced on my vehicle.

I hope this helps anyone that might have faced such incident (hopefully no one!!) and mind you that the above applies to the Hybrid model only.
I started getting exactly the same problem you have today, My car is Xtrail 2019, it has only 5000Km so far.
I am planning to take it to the dealer workshop tomorrow bu I am worried to drive it or have it transported.
 

·
Registered
Joined
·
1 Posts
After getting hold of Repair Manual for Nissan Roque Hybrid 2017-2020, and reading the Brake Control System and Brake System accordingly, the Fault code C1111 is also related to Pump Motor. The possible causes are described as follows:
• Harness or connector
• Hydraulic brake booster unit
• Fusible link
• 12V battery power supply circuit
• 12V battery

The dealer's remarks and what actually happened to me on the road, now make sense. For some reason, mostly due to
malfunction of motor, motor relay, accumulator or accumulator pressure sensor, during EV mode and continuous braking conditions in traffic, the system's brake pressure decreased. The RED Brake light came ON due to one of the mentioned reasons and at some stage the brake pedal become hard due to lack of brake pressure.
The reason for the Brake System Warning Lamp (Orange) to come ON at some stage, is mostly because the Control Unit was trying to operate the Pump Unit in order to increase brake pressure, but the pump was not working, or working intermittently with no brake pressure increase.
Taking into consideration all of the above, I would suspect either a pump motor malfunction, a motor relay malfunction, an accumulator pressure release valve that stuck open, and of course, a bad electrical connection to any of these components.

Anyway, I am still waiting for the new Hydraulic Brake Booster Unit to arrive and be replaced on my vehicle.

I hope this helps anyone that might have faced such incident (hopefully no one!!) and mind you that the above applies to the Hybrid model only.

Hi I too had same problem for my Nissan Xtrail 2016 T32, actually I repaired replacing all the faulty items. As per the mechanic, it similar like master pump repairing in other vehicles. Im living Sri Lanka and can only found few places for repair with a one year guaranty. at the moment its functioning smoothly At the time of issue my millage around 66000 km can posted my repairers Contact Number Choolan - 00947738011 -Edirisinghe Motors - Mirihana, Nugegoda, Sri Lanka.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top