Nissan Forum banner
21 - 35 of 35 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #22 ·
@Shadow_Death Happy to report that the car is finally back to its brand new car like working state. IAC and TB are not completely clean though but the car doesn't idle badly anymore so the AC works but I had to do Idle Relearn because when I tested the car it was still idling badly. One more issue thats solved is car stalling even when the AC is off and its thanks to your battery picture in your thread. I fixed that funny looking battery wire that I thought was normal.

Although the AC still doesnt blow cool air during idle. I had a mechanic check the Alternator and he said it was still working perfectly despite my dad never replacing it. Thoughts?

Sent from my Moto G using Tapatalk
 

·
Registered
Joined
·
81 Posts
@Shadow_Death Happy to report that the car is finally back to its brand new car like working state. IAC and TB are not completely clean though but the car doesn't idle badly anymore so the AC works but I had to do Idle Relearn because when I tested the car it was still idling badly. One more issue thats solved is car stalling even when the AC is off and its thanks to your battery picture in your thread. I fixed that funny looking battery wire that I thought was normal.

Sent from my Moto G using Tapatalk
That is great news. I'm glad all that helped. :D
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #26 ·
Try calling a local Nissan Dealerhip to see if there are any recalls for that car for the A/C. Apparently there are recalls for the 04 Nissan Titan for that very issue.

They will probably ask you for the vin number.
I will call them today and see if they are any recalls for this car. Although what are the possible issues causing this to happen? Do you have any rough idea?

Sent from my Moto G using Tapatalk
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #29 ·
Called Nissan yesterday and I was told that they were recalls for this car but nothing related to the problem we have right now(Faulty Air Bags and Engine Cooling issue for 2.5L engine), and plus my dad took the car for the recalls I'm pretty sure. At this point maybe I should look at the fans and see if they are clogged up by any chance?

Sent from my Moto G using Tapatalk
 

·
Registered
Joined
·
81 Posts
Called Nissan yesterday and I was told that they were recalls for this car but nothing related to the problem we have right now(Faulty Air Bags and Engine Cooling issue for 2.5L engine), and plus my dad took the car for the recalls I'm pretty sure. At this point maybe I should look at the fans and see if they are clogged up by any chance?

Sent from my Moto G using Tapatalk
I suppose the AC could be low on refrigerant. This was my original thought until I did a search for that problem.
 

·
Registered
Joined
·
81 Posts
@Shadow_Death So I did finally figure out the issue and it was IAC that needed to be replaced. Wasn't working as properly as I thought but the car works now

Sent from my Moto G using Tapatalk
I'm glad your issues are worked out. :D


I also finally figured out the check engine light and transmission issues on my car. Turns out that car DOES have 2 VSS'. Best I can tell by the FSM is that one goes to the speedo and the other goes to the TCU or ECU. The one that goes to the TCU/ECU had a short in the wiring and as soon as I moved it the car began running great again. A new replacement is 258.00 USD so I went to the local junk yard and found one. I paid 9 USD for it. :D
 

·
Registered
Joined
·
2 Posts
My dad has a Nissan Sentra 2004 with a 4 cylinder 1.8 litre engine that has done 258,333. Recent repairs were track-rod ball joints for the front right tire, alternator belt, engine mountings, drum brake shoes, battery. The only repairs I did was battery and alternator belt.

We had recently done these repairs for our 12 hour road trip to Dubai, and after doing all of these repairs car was running almost perfectly except it would stall but VERY rarely(no CEL light back then so we couldn't check). The car was acting brand new, and didn't cause us a single issue during our travels.

The issues started recently after a month of our travelling when one day when my dad started his car idle speeds started fluctuating, and the moment he would turn on the A/C, it would get worst. The car feels like as if its losing power, and stalls. I couldn't pull codes because the Check Engine Light randomly disappeared after it was on for a day.


The car also has this problem of stalling in the middle of the road when the AC is on and sometimes it even stalls even when the AC is NOT ON. Is this a faulty Alternator issue? I am guessing this because whenever we turn on the AC and the car is stopped the lights in the car are flickering when we look closely and it struggles to pick up speed after stopping in a red light. It also doesnt blow cool air when idle but when we are driving its fine.

The final problem is that my dad sometimes has to now keep his foot on the gas pedal to start the car.

Now for the idle speeds fluctuation part I know I have to clean IAC and TB, but I have no idea where are these located in this car and Google has no info on this. If anyone could tell me about this I would appreciated it. I know it sounds like the car isn't maintained from what I have said but I swear these problems came outta nowhere. My dad is taking his car for full inspection to see what is faulty and what is not so that the car doesn't bother him anymore, but me and him like to know how much currently damaged his wallet is.

Thank you in advance for any responses I get.

Sent from my Moto G using Tapatalk

since your lights are flickering some, have you tried to clean any ground cables around the engine? A dirty ground wire would make a car do weird things. I just replace the whole ground cable for my 2004 Nissan and it seems to be a lot better. It would charge a steady rate not fluctuate so much. I am having an ongoing problem with my 2004 Nissan the same engine the code is P0011 and I cannot get it to go off. I don’t know what else I can try
 

·
Admin and Sup Mod keeping the peace
Joined
·
8,189 Posts
since your lights are flickering some, have you tried to clean any ground cables around the engine? A dirty ground wire would make a car do weird things. I just replace the whole ground cable for my 2004 Nissan and it seems to be a lot better. It would charge a steady rate not fluctuate so much. I am having an ongoing problem with my 2004 Nissan the same engine the code is P0011 and I cannot get it to go off. I don’t know what else I can try
The P0011 code can be caused by the following:
  • - A marginal crankshaft position sensor or a marginal Camshaft position sensor.
  • - Accumulation of debris on the signal plate pick-up portion of the camshaft or a chipped signal plate of camshaft rear end.
 
21 - 35 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top