Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,

Just trying to find some help with a little problem i have. 95 Nissan Bluebird SSS

Problem seems to be my indicator module. It smells burnt and it has smoke coming out of it today.

When the indicator switch is in its normal spot there would be a ticking noise from behind the dash/cluster, from what i assume would be the flasher unit.
If i moved the indicator lever around a bit it would eventually stop so i didnt think much of it.

Then twice on seperate occasions there was a burning smell. Today there was a burning smell and then smoke came out from where the indicator lever goes in.

I pulled the plastic cover off from around the steering column and pulled out the indicator module or whatever you call it. and it smells burnt.

Any suggestions on what the problem may be? Do i just need a new indicator module or flasher unit? Or is there something else majorly wrong?

Oh and just to clarify, when the ticking occurs with indicator in its normal spot none of the indicators actually turn on nor do the indicator lights on the dash turn on. All lights and indicators work normally apart from that.

Thanks in advance for any help.
 

·
Registered
Joined
·
1 Posts
Same issue

I have the same issue. Without looking too hard into it, I can assume I need a new indicator combo. Does anyone know if s14 combos are compatible? They look very similar in pictures.

Cheers In advance.
 
1 - 2 of 2 Posts
Top