Nissan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
1 month ago i came across a deal to buy an 84 300zx turbo fully loaded
for 100 dollars , it supposedly didn't run and i know for a fact it sat for 18+
months. the girl(age 16) who drove it at the time said it just stopped running while she was driving it so her parents had it towed home and tryed to start it a couple of time and never succeeded, anyway i got it back to my house put a new batt in it and rolled it over a few times then looked at the gas gauge and it was empty so i grabbed a can and put 2 gallons in it and have been driving it ever since .................good deal huh?

anyways the turbo seized up in it and im wondering what kind/size turbo it has (stock) also looking for a good boost controller ,blow off valve, intercooler
i have removed the a/c compressor (didn't work anyway) and the power steering pump (same thing) and have added an aftermarket trans cooler
oh yeah i cut off the cat and added a flowmaster

if anyone can give suggestions feel free, also what everyones opinion on my exaust setup

thanx chris
 

·
Registered
Joined
·
23 Posts
Discussion Starter #2
forgot to mention the car still runs great w/o the turbo functioning
i was planning to sell it nut after driving it a while im gunna keep it
ive got a budget of a lil over 1k to spend on it and im a mechanic/custom car builder and have a shop and tools so hopefully ill reach my goal of 300hp

any advise would be greatly appreciated
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
............

kutrecords2005 said:
forgot to mention the car still runs great w/o the turbo functioning
i was planning to sell it nut after driving it a while im gunna keep it
ive got a budget of a lil over 1k to spend on it and im a mechanic/custom car builder and have a shop and tools so hopefully ill reach my goal of 300hp

any advise would be greatly appreciated

anyone? .....................................i posted a lnk to the pics of my 300 on my signature
 

·
Registered
Joined
·
5 Posts
its a t3 most likely, none water cooled,as for boost controll go to boostvavle.com about 50 for manual boost controller and all stuff needed to put it in,try and find a spearco 221 core(good luck),you can safely run 10 psi if the car is in good shape, as for bov there are to many to tell you which to get, go to z31.com they have a faq section with alot of good info on upgrades and limits for stock components.
 

·
Banned
Joined
·
3,554 Posts
1984 was a Garret T3 turbo.

I use the manual boost controller from www.boostvalve.com and never had a problem with it.

I also have a TurboXS H-34 BOV and it works great.
 

·
ZPOOLNZ
Joined
·
1,609 Posts
It is a T3. Swap in a T3 from an 85-87 and enjoy water cooling. Get a 3in turbo back exhaust system from certified muffler, get a K&N cone filter, Boost valves MBS will be good. Go to www.amzperformance.com and look at their intercooler cores. Problem is your Auto will not survive these modifications. Start looking into a 5spd swap.
 

·
Registered
Joined
·
5 Posts
there is are mods you can do to the auto if you want to keep it, on z31.com there is a setion somewhere with the instructions that level ten does to make them hold 500 plus hp, ill see if i can find the exact place it is but if you search for level ten on the search on z31.com you should be able to find it or ask and someone there might have the link. i run 10 psi all day long and my car has 130,000 raged on miles and it still hold strong and is just now starting to get weak but its got so many miles on it how cares. as for the upgrade it gonna have to be done by a tranny mechanic unless your good with them and can understand what it tells you to do. other wise just swap in a 5speed.level ten themselves also do this mod but i think its kinda pricy but you gotta pay to play.
 

·
ZPOOLNZ
Joined
·
1,609 Posts
Yeah the level ten is by no means cheap. The 5spd is far superior unless your building an all out drag car. At 10psi your at the limit for the trans already. It should last longer then 130k miles, but it will not survive much more.
 

·
Registered
Joined
·
5 Posts
well i have no slip in it its just when put in drive it takes a while to engage(gotta thank the 16 year old kid i saved it from for that) but for 600 bucks i realy cant complain. but he realy did a number on it, the turbo was fried had to replace all the no name plugs,wires etc he put on it but the thing runs damn strong, im probley going 5 speed soon but i figured id give him the info anyways since some people just refuse to drive a 5speed.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #10
shromy said:
well i have no slip in it its just when put in drive it takes a while to engage(gotta thank the 16 year old kid i saved it from for that) but for 600 bucks i realy cant complain. but he realy did a number on it, the turbo was fried had to replace all the no name plugs,wires etc he put on it but the thing runs damn strong, im probley going 5 speed soon but i figured id give him the info anyways since some people just refuse to drive a 5speed.
trust me id rather have a 5 speed any day but seeing as i happen to manage a transmission shop i wont have a problem building/getting mine built
i got into the tear down today because of the fried turbo (its completely seized up) and man they put it in a pain in tha @$$ place but i bought a turbonetics t3 got a good deal on it and it has a warranty and a fresh rebuild on it so ill have it done tomorrow i also got a blitz bov and a 240sx throttle body any one have anything good/bad to say about any stuff i bought just wondering
 

·
Registered
Joined
·
23 Posts
Discussion Starter #11
shromy said:
well i have no slip in it its just when put in drive it takes a while to engage(gotta thank the 16 year old kid i saved it from for that) but for 600 bucks i realy cant complain. but he realy did a number on it, the turbo was fried had to replace all the no name plugs,wires etc he put on it but the thing runs damn strong, im probley going 5 speed soon but i figured id give him the info anyways since some people just refuse to drive a 5speed.
and that problem of delayed engagement could be a couple of things
front pump or a fluid deliver prob (ie clogged filter) try servicing the trans first and see if it clears it up
 
1 - 11 of 11 Posts
Top