Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi all, this will be my first post on here so don't hate on me too hard!

i am a complete noob when it comes to any z car much less the z31. I own a 2003 SRT-4, and do all my own work, so im pretty good with tools and repairs.

now, onto the car.. monday i bought a 1985 300zx Turbo for $500!! the previous owner said it needed a new fuel pump, ive been looking around and it looks like the walbro 255 will work. first thing i checked was the fuses, and the one for the fuel pump was blown! so i replaced it, but still nothing. also, idk if its broken or not, but the dash(digi) doesn't show any fuel in the tank, and the gas light is on.... so i pulled up the back carpet today, and found this...





looks like the connections for the fuel sender are screwed, but that should only affect the fuel gauge correct?

any help here guys?

thanks,
-Keegan
 

·
Registered
Joined
·
13 Posts
hi all, this will be my first post on here so don't hate on me too hard!

i am a complete noob when it comes to any z car much less the z31. I own a 2003 SRT-4, and do all my own work, so im pretty good with tools and repairs.

now, onto the car.. monday i bought a 1985 300zx Turbo for $500!! the previous owner said it needed a new fuel pump, ive been looking around and it looks like the walbro 255 will work. first thing i checked was the fuses, and the one for the fuel pump was blown! so i replaced it, but still nothing. also, idk if its broken or not, but the dash(digi) doesn't show any fuel in the tank, and the gas light is on.... so i pulled up the back carpet today, and found this...





looks like the connections for the fuel sender are screwed, but that should only affect the fuel gauge correct?

any help here guys?

thanks,
-Keegan


you are most likely right...but it still may not work cuz the pump and sending unit may work off the same ground, im not sure, but if ur repairing the wires u gotta be careful cuz the gas however ur fixin it i dont know....that whole unit in the pic is the pump as well...take all the screw out around it n take the unit out n try to repair...remember to un-hook the battery.....dont worry these cars are pretty simple to work on .good luck.....

and if u need parts i have alot of 300zx parts .....make me a resonable offer....u will be surprised. not askin alot $$.....jus need to make some room in my basement.....i have hood, trunk, fenders, headlights n assembly. doors. front & back bumper.. lots of interior peices... all the trim... alll the windows except windshield......spare tire...T-TOPS,,,,windshild washer resevoir....side mirrors....signals..rear lights..rear storage for 2 seater... there may be more but i cant think of anything else..there is most likely more parts. i dont have pictures but the parts are in very good condition WITH NO RUST...mint black turbo seats....colour is black.....take one take all...car is parted, DO NOT HAVE THE CAR ANYMORE...jus parts
 
1 - 2 of 2 Posts
Top