Nissan Forum banner

1 - 4 of 4 Posts

·
even better the 2nd time
Joined
·
2,719 Posts
Discussion Starter #1
before you tell me that i drive a B14...im asking this for a friend
he sent me this e-mail

"set the ride height on my front coilovers exactly the same...but the camber on one side is different...causing it to toe in at the top and rub the tire...whats the problem?"
 

·
Registered
Joined
·
66 Posts
sounds like you need an alignment. Get a qualified shop to do a FULL ALIGNMENT, including toe and camber. Sounds like either something sits differently with the new coilovers or something was bent before and went unnoticed until now. I would make sure the installer of the coilovers definately knew/knows what they were doing. Just out of curiosity, what is the tire rubbing on?
 

·
even better the 2nd time
Joined
·
2,719 Posts
Discussion Starter #3
-this is his response-

The spring. The Hub it self is tilted in at the top.
 

·
Registered
Joined
·
58 Posts
Radioaktiv said:
-this is his response-

The spring. The Hub it self is tilted in at the top.
the tire tilted in at the top is camber not toe and unless the car has been lowered too much there must be something bent in the suspension the only way to adjust the camber in those cars is to buy some sort of a camber correction kit or have a good alignment shop notch the strut mount holes to adjust the camber anyway hope your friend can fix this problem with the minumum of trouble and money...Good Luck!!!
 
1 - 4 of 4 Posts
Top