Nissan Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
ok so here what goin on, i am originaly from houston and i just moved to trinidad well i also just bought a 95 pulsar GTI...not the GTI-R. it has the sr18-de motor in it. here lies my problem.


when im driving the car i have no problems. when i run the car hard and then park up somewhere leaving the car running it starts to over heat. no fans are coming on. so i am about to change the sensor that tells the fans to come on and we will see what happens. the weird thing is when i run the car normal from point a to point b you can still hear the water bubbling when you get out even if the temp has not reached high?????

BTW, this is a jdm car RHD
 

·
Super Moderator
Joined
·
3,202 Posts
check the coolant temp sensor and/or the thermostat.
what a change, from texas to trinidad???
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
yeah it's been really cool. living in the states and being in the import scene in houston and now being in the import scene here is awesome cuz there is TONS of JDM shit around here... skylines a plenty.. pretty much al the shit i wanted to see living in america is here to view and participate at any time!


as far as the coolant temp sensor goes is that the small blue sensor located just above the oil filter. top left on the engine below the intake manifold?
 

·
Super Moderator
Joined
·
3,202 Posts
that sounds more like the knock sensor...
my coolant temp sensor on my altima is on the intake manifold near the idle air control valve.
 
1 - 4 of 4 Posts
Top