Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey guys. i need help,, my 94 sentra,, base model,, has been acting strange,, it will have imtermitent stages to her running,, i bought the car on fri and by mon she was dead,, on the side of the road, she got a new fuel filter and i thought this provlem was allevieated, but shes still acting up... what she dioes is she will go for a while no problems and then all the sudden whe will start sputtering and makle a hissing sound,,, even clanking,,all the while losing power,, the whe'll get to about 15 or 20 miles and hour and just start junping and shaking,, making all kindf of horrible metal to metal sounds,, i think sunce it was diagnosed that hetr fuel fliter was bad,, that i should replace the shole fuel syatem,, tank and all,, what do u think?
 

·
My ass, your face
Joined
·
3,520 Posts
metal clunking and whatnot? just by what im understanding..the car is a 5spd right? sounds like a transmission problem if thats the case...if it is a 5spd, next time the car is sputtering, put the clutch in and put the car in neutral..see what it does.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
i think its more in the fuel injectors and spark plugs,, im changing the plugs in the morning,, then hoping its not in the tranny,, but since it is a 5 speed,, at least it would be a bit cheaper than the auto,,, thanks
 

·
Registered
Joined
·
1,014 Posts
You need to evaluate that the MAF wiring or sensor may be bad or pulled off. I would also look into a Coil. The coil if going bad will give you this surging and bucking, if the spark is not constant. Look over that first. Test the coil or replace it if you can find a spare in a yard. Its not the injectors, all of them will not give you that, you will get a rich condition from the injectors if they are leaking. The MAF is usually the issue with the bucking, try a good MAF and make sure the wiring is not pulled off th harness plug.
Chris 92 classic
 

·
scrambled egg
Joined
·
114 Posts
check your vaccum system. do a tune up and i would check all of the wiring harness under the hood. i wouldnt think its the maf because the maf will limit you to 3500 rpm or so.

check your clutch for the metal to metal sound and when you change the oil make sure your not draining your bearings out with the oil.

the bucking i would imagine its just in the plugs wires cap, your distributor might be going bad.
 
1 - 5 of 5 Posts
Top