Nissan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
My frick'n car keeps dying on me. When at idle the rpms just drop and my car dies. So every time I pull up to a red light I have to floor it in N. How fun is that, good thing I have a gay muffler so people can think I'm a damn ricer kid.


anyways, any ideas on whats causing this?
 

·
Will work for beer
Joined
·
2,696 Posts
check your EGR valve as well. 3rd gens have a history of the solenoid going bad and holding the EGR wide open.. this causes horrible idle..

unplug the vacuum hose goign to the EGR and stick a screw or something in the hose to seal it off.
see if that helps.
 

·
In Ur Threadz - Deleting!
Joined
·
1,906 Posts
Have you checked all your vacuum hoses? My car kept dying like yours is and would idle horribly. Popped the hood and one of the major hoses connected to my midpipe had come loose.

Are you getting any codes?
 

·
Registered
Joined
·
14 Posts
i could sit here and hate on the pad drivers but.. i dunno if trucks are the same but my f-150 did the same thing i replaced the egr valve and that didnt help... there was actually a bad hose on it and i replaced that and it worked fine after that... i would check the hoses like they mentioned above. until then i bet you get a lot of people thinking you are wanting to race hahahaha. The only thing is when it happened to me it didnt just die at stops it would do it whenever and wherever it would die when i'm going around a corner and so forth.
 

·
Bigger IS Better
Joined
·
58 Posts
probably not the same problem but my Q45 did that when i had the jwt popcharger (super hai) on during the summer. underhood temps are super high and combined with hot outside temps the car frequently threw cels while driving and stalled when coming to a stop. i cut a big hole below the filter for more air but i still don't use the popcharger during the summer.
 

·
Registered
Joined
·
14 Posts
i believe its like the electric or engine gas recurculation or something i'm a n00b on cars i just know that generally from my experience that when that happens its the valve or the hoses.. dunno where it is in a pad but i can show you in an f-150 :thumbup:
 

·
Registered
Joined
·
2 Posts
exhaust gas recirculation valve, and also i remember when i had my eclipses the throttle position sensor caused that on two of them but i havent heard about anything like that on a nissan so id go with the egr valve and vacuum hose check first
 

·
Registered
Joined
·
60 Posts
e34bmw_a33max said:
My frick'n car keeps dying on me. When at idle the rpms just drop and my car dies. So every time I pull up to a red light I have to floor it in N. How fun is that, good thing I have a gay muffler so people can think I'm a damn ricer kid.


anyways, any ideas on whats causing this?
ok i wont say anyting
 

·
All Show...trust me!
Joined
·
164 Posts
How do you do at high rpm's...over 2200. If it gives you problems there it may be your MAF.
Also what mods do you have so I can get a better idea to help.

Gabriel
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Tonight it idled fine, until i give it a little gas and let off, then the rpms drop and it dies. I have no engine mods at all.
 

·
Back in a Nissan....
Joined
·
105 Posts
e34bmw_a33max said:
Tonight it idled fine, until i give it a little gas and let off, then the rpms drop and it dies. I have no engine mods at all.
My 2k did that when I had to replace the MAF. It was only like $75 with our discount from courtesy. I was shocked.
 

·
All Show...trust me!
Joined
·
164 Posts
e34bmw_a33max said:
Tonight it idled fine, until i give it a little gas and let off, then the rpms drop and it dies. I have no engine mods at all.
Does it stall at the high rpm's? If it does then it is your MAF. If not then it is a vacuum leak and you will have to try and chase it down...this is not very easy.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #17
LatinMax said:
Does it stall at the high rpm's? If it does then it is your MAF. If not then it is a vacuum leak and you will have to try and chase it down...this is not very easy.
it's not my MAF then. i'm giving up and taken it to the dealership....JK....i'm gonna take it to a hole in the wall place that was bad ass when i had the bmw.

thanks a lot guys.
 

·
Registered
Joined
·
0 Posts
I had same problem before, my car stalled when I come to stop. I cleaned Throttle body and IACV (Idle Air Control Valve), and the problem was resolved. You could try that.

Recently my RPMs started to drop again down to 300 then goes to 500 and stay there. The good part is that engine does not stall.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #19
well, turns out they couldn't find anything wrong with it at all. so i just handed over my 10 bucks.
 
1 - 19 of 19 Posts
Top