Nissan Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, I need help from all you experienced people out there.

My 98 GXE with 95K starts, but the powersteering does not work. The belt near the alternator did not run for a while & when it finally did it wobbled and squeaked, there is a lot of noise from that general area which I had been hearing for the last couple of days, too bad should have taken it in sooner. When I let the car run in idling speed the RPM rose to 3000.

I'm not sure how to take it to the mechanic, the steering is too tight and don't know what else I may damage if I drive it. When I started it, it smelt like burnt rubber.

What do you think the problem is? any ideas tips on how much it would cost. I've been taking the car in for regular oil changes but never thought I'd see this day.

Thanks for the help.
 

·
Registered
Joined
·
128 Posts
Sounds like the belt came off.

Ineedhelp said:
Hello all, I need help from all you experienced people out there.

My 98 GXE with 95K starts, but the powersteering does not work. The belt near the alternator did not run for a while & when it finally did it wobbled and squeaked, there is a lot of noise from that general area which I had been hearing for the last couple of days, too bad should have taken it in sooner. When I let the car run in idling speed the RPM rose to 3000.

I'm not sure how to take it to the mechanic, the steering is too tight and don't know what else I may damage if I drive it. When I started it, it smelt like burnt rubber.

What do you think the problem is? any ideas tips on how much it would cost. I've been taking the car in for regular oil changes but never thought I'd see this day.

Thanks for the help.
 

·
Super Moderator
Joined
·
3,202 Posts
im thinking the same thing... why it came off though is what you need to find out. can you take pics of it?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Sorry, I should have updated the situation... I figured out what it was, the idler pulley had comeoff, fixed it and also changed the belts. The cars' fit as a fiddle now. Thank you very much for posting your suggestions.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top