Nissan Forum banner

1 - 10 of 10 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hello everyone,

I have a 1989 GA16I (w/CA emissions) that has developed an extremely bad habit of jerking/twitching when going down the road at speed. Ocassionaly it stalls when it idles down at a full stop. The strange thing about this problem is that it only happens when it gets hot outside (above ~70F). I am thinking that it could be some sort of thermal breakdown with the coil? I have replaced plugs, wires, dist cap and rotor. The car does not overheat it operates midrange on the temp guage. If I were having this problem with my Fiero I would go directly to the ignition module but according to Haynes this thing doesn't have one (that I can find). Any help would be greatly appreciated.
 

·
Registered
Joined
·
475 Posts
Sounds like it could be a dirty fuel filter or perhaps a defective/ worn out fuel pump. I'm having the same problem in the Sentra B13 w/GA16DE engine. Rough idle but doesn't shut off and often, like you said "jerking/twitching," but not too serious. If it's shutting off then it could be the fuel pump although I can't see temperature being a problem there.

Only other thing I could think of is the CAT is gone/plugged causing the engine to choke and shut off.

I'll post tomorrow and let you know if the fuel filter replacement worked...it did on the other 1995 B13 Sentra we have so maybe I'll be lucky a second time although the "check engine" light wasn't on in the other car when I changed it. :(

---------------------------------------------------------------------
Update: July 4th, 2002 - 8:50am - Happy Independence Day to all our American friends :D

So far so good. The car seems to be working a little better. After the torment of removing the hoses and 30 minutes of my time it better. It doesn't idle as rough or sputter like it did before. I find it starts a little easier as well. I won't know for sure if it really helped till I drive it a bit more to see if the problem comes back. Good Luck.

Greg
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I guess there were a few things that I didn't mention, I have also replaced the air filter and fuel filter, didn't make a difference. I never have any problems starting the car, just likes to stall occasionally when coming to a complete stop. I have checked all the vacumm lines, didn't find any problems. When the driving the car and it starts jerking (doesn' happen all the time only when hot out) it is almost as if the car is stalling out and because it is moving it is restarting itself much like a push start. I don't think it is the cat, had this same problem last year and by the time I got annoyed enough to do something about it the problem subsided because it cooled down. I had an emission test done about 3 months ago and it passed with flying colors. Because of the transient nature of this problem, I don't want to take it to a mechanic and spend $65/hr on diagnostics for the squirrel who would more than likely be on vacation that day.
 

·
Registered
Joined
·
475 Posts
Hmm...I was going to suggest that the O2 sensor could be gone but you said you had an emission test and it was fine.

Reason why I though it was this is because my brother's '85 BMW 318i had the same problem you are having. The car would have trouble staying going (slowly stall at stop), he would have to rev the engine while at a lite so it wouldn't cut out. It also had the same symptom you mentioned "jerking/twitching" while on the highway as far as I can remember...this was 2 years ago as the car is in pieces since he's restoring it.
He replaced the O2 sensor and it worked fine for the most part, besides the fact he can't get into 5th gear.
 

·
Cone Dodger
Joined
·
3,093 Posts
stalling......

okay if ya'll say it dies when coming to a stop and ya'll need to rev it up so itwon't die, it could be the idle air control valve, it could be sticking, also that 318 could also have a defective crankcase vent valve, i don't know.......
 

·
Registered
Joined
·
20 Posts
Same problem -- stalling coming to stop

I have the same problem with my 91 Sentra 5-sp stalling when coming to a stop. I've changed the fuel and air filters and the spark plugs but that hasn't helped. I've seen idle air valve and 02 sensor mentioned -- can anyone tell me where i might find those things on the engine? Also, can anyone tell me how to check the engine codes on a 91 Sentra? I saw a post for checking them on a 96 Sentra. Would it be the same? Thanks for any help.
 

·
DNE's VZR Conversion
Joined
·
6,079 Posts
i get stalling when i leave my A/C on 2 long. but other than that i dont got that problem
 

·
Registered
Joined
·
475 Posts
Just a guess but you could be draining your battery with the A/C on. The alternator is unable to keep it charged and the car eventually shuts off unable to produce a spark in the engine.

Could be a ground out, in need of a new battery or alternator.

Again....just a guess.

Greg
 

·
Tuner/Mechanic
Joined
·
266 Posts
mine did the same thing as all of you said before this post, you know what the problem was, a loose and sometimes coming unplugged MAF wire. this caused the car to surge, die at idle, jump, bump, and squiggle down the road, it sucked. anyway, do the famous wiggle test on the wires and see if that helps. this fixed mine, hopefully you all won't have to go through the 5 days of hell like i did. just my .02.
 
1 - 10 of 10 Posts
Top