Nissan Forum banner
1 - 2 of 2 Posts

· No Nissan Yet
Joined
·
142 Posts
bigj316 said:
I've got a 1990 s13 hatch back the engine has a miss at about 2000 rpm and at idle sometimes. I've taken it to a number of mechanics and had diagnostics done on it. Diagnostic reads normal. I'm getting spark to all the cylinders and i replaced all the feul injector connectors. Also the rear end of the car shakes upon acceleration just in the begining. If anyone has any info on these subjects please respond. Your information would be greatly apprieciated.
first, how does your ignition look?(cap, rotor, wires). when was the last time you did a tune up? i will go from there when you tell me when these parts have been replaced. check to see if the mass air flow boot is ripped and the hoses going to them are in good shape. is the Mass air door type meter or wire type? check to see if all that is good also.

your shaking maybe a carrier bearing or a bad u-joint. i am not sure if they use a carrier bearing or not in your car.
 

· No Nissan Yet
Joined
·
142 Posts
Re: Engine Miss

bigj316 said:
Thanx for the reply, The last time I did a tune up was about 10,000 miles ago. I already checked all that stuff it all looks fine no deposits or anything. I'm not real sure what you mean by mass air flow boot can you describe it a little more I Know where the MAF sensor is. Take me from there. I have a Injen aftermarket intake and an aftermarket exhaust ( not from cat back) just muffler. I was reading on 240sx.org that my problem could be the air induction valve, so I took it apart last night and cleaned it up real good, it's better but still not right. I've thought about jus changing the MAF sensor and the O2 sonsor. What is your thought on that.

Could the shaking come from an arm bushing in the rear or somthing.

Thanx

Big j
So you have an aftermarket intake? well dont worry about the boot, but do make sure all the clamps are tight. O2 shouldnt cause the miss at a certain RPM. how are the plug wires?

As for the rear, i looked at the suspension and only thing i can see is what i mentioned above. also, your driveshaft could've lost a weight causing it to become unbalanced.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top