Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
All,

I have a 95 GA16, with Headers, short-ram intake, and stage 2 clutch. I resently took a drive down to beautiful NC and noticed about 50-65% up a fairley steep hill, the cruise controll truns off while on "Cruse" light on the dashboard begins blinking. So I turn off the Cruise wait until I have gotten to the top of the hill and turn it back on again..most of the time it works again until the next hill!!

In addition, when I attempted to take over, by pushing the pedal to the metal!!! the RPMs increase but the speed does not...??

I know I have to replace the motor mounts as the car has 150,000, but the dead give away is the mounts are dry and cracked!! wihch might be causing the lose in compression resulting in both the above situation.

Other from that, any ideas what might be going on with my girl??

Thanks for all the help...


Jamie
 

·
Registered
Joined
·
313 Posts
It sounds like you girl is getting a bit tired. She is more than likely in need of some dire attention. From the sounds of it ther more than likely is some valve train wear. did the car always handle hills like that in the past while in cruise control?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Occasionally, but could not determine when as there aren't alot of hills where I live. However, the acceleration issue never happened before. Now when I floor it from a the line it feels as if the clutch needs tightening, as her RPM increases but speed remains :eek:(

Is there a way for an newbie mechanic diagnose the valve train?

Thanks
 

·
Registered
Joined
·
4,208 Posts
The Cruise drops out when car does not maintain speed and slows by about 10 mph.
My manual does this a lot, have to shift down, even when new !!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
There is loss of about 2-3 miles before the cruise issue occurs.

When I push the acceleration peddle moving with the cruise acceleration, at the same point when the cruise turns off is where I notices the RPM issue occurs.

What needed love and care would anyone suggest?

Thanks!!
 

·
Registered
Joined
·
4,208 Posts
Occasionally, but could not determine when as there aren't alot of hills where I live. However, the acceleration issue never happened before. Now when I floor it from a the line it feels as if the clutch needs tightening, as her RPM increases but speed remains :eek:(

Is there a way for an newbie mechanic diagnose the valve train?

Thanks
check the clutch cable free play.
It sounds like your clutch is toast.
 

·
Apprentice Technician
Joined
·
784 Posts
There is loss of about 2-3 miles before the cruise issue occurs.

When I push the acceleration peddle moving with the cruise acceleration, at the same point when the cruise turns off is where I notices the RPM issue occurs.

What needed love and care would anyone suggest?

Thanks!!
while in cruise, if you touch the throttle, or the breaks, cruise shuts off... in any car.

clutch sounds dead, mounts you need to replace regardless.
 
1 - 8 of 8 Posts
Top