Nissan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
I have a 95 Sentra XE and my engine has been getting louder and louder but rides like brand new. i think i have vacum leaks but dont know where to start on getting rid of those. My engine light keeps coming off and on with no ride difference. i got the code read off once but all they said was exhaust system. What could that be? and i have plans on installing pace setter headers and cat back exhaust and injen air intake are they easy to install or should it go to a shop?
 

·
Drop-Out
Joined
·
1,892 Posts
Sounds like you either have a rotten or broken exhaust..And on the header, do yourself a favor and get yourself a Hotshot
 

·
Registered
Joined
·
306 Posts
Stromung and hotshot header

I installed my hotshot header w/ the stromung exhaust,,

the car runs fine. but at some points. i think i smell some fumes, like gas. The whole install was a bitch for me, but after hours of work, i finally had the whole thing installed, the cat. i'm using is from a 96' se-r (used).

1. should i not worry?
2. tighten the bolts?

no have problems occured w/ the car, I have the o2 sensors in and they work, only because no lights have pop up. I figured it is just me, i do plan on to buy a better cat. from Random Technology. And better the wiring for the 2nd o2 sensor, as i did a poor job on extending the wires. but since no error lights have come up, i figure it is ok.
 

·
Registered
Joined
·
102 Posts
huskya83 said:
I installed my hotshot header w/ the stromung exhaust,,

the car runs fine. but at some points. i think i smell some fumes, like gas. The whole install was a bitch for me, but after hours of work, i finally had the whole thing installed, the cat. i'm using is from a 96' se-r (used).

1. should i not worry?
2. tighten the bolts?

no have problems occured w/ the car, I have the o2 sensors in and they work, only because no lights have pop up. I figured it is just me, i do plan on to buy a better cat. from Random Technology. And better the wiring for the 2nd o2 sensor, as i did a poor job on extending the wires. but since no error lights have come up, i figure it is ok.
damn how did u install everything yourself. i thought the exhaust had to be welded or something? but then again im not to bright when it comes to this so i duno... thats impressive tho... i'm sure if there is no warnings u should be cool... :thumbup:
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,282 Posts
huskya83 said:
I installed my hotshot header w/ the stromung exhaust,,

the car runs fine. but at some points. i think i smell some fumes, like gas. The whole install was a bitch for me, but after hours of work, i finally had the whole thing installed, the cat. i'm using is from a 96' se-r (used).

1. should i not worry?
2. tighten the bolts?

no have problems occured w/ the car, I have the o2 sensors in and they work, only because no lights have pop up. I figured it is just me, i do plan on to buy a better cat. from Random Technology. And better the wiring for the 2nd o2 sensor, as i did a poor job on extending the wires. but since no error lights have come up, i figure it is ok.
New exhast and manifolds sometimes smell for a while. I would describe it as burnt oil or paint kind of smell, not gas. Since you are only working on the exhast side I think you are fine. Give it a week and see if its all ok then.
Good luck......
 

·
What is Seven Ten for?
Joined
·
2,917 Posts
maybe one of your gaskets are blown as well.

and the hotshot header and stromung exhaust bolt up with no welding required.

go to sentra.net and read up a bit on headers and exhaust before you get a PS or any header other then hotshot.

You can usually find them used in the classifeds here for 200-250, the gaskets will cost you about 10-15 from Mossy Nissan.
 

·
Mofo
Joined
·
2,225 Posts
curtisj85 said:
I have a 95 Sentra XE and my engine has been getting louder and louder but rides like brand new. i think i have vacum leaks but dont know where to start on getting rid of those. My engine light keeps coming off and on with no ride difference. i got the code read off once but all they said was exhaust system. What could that be? and i have plans on installing pace setter headers and cat back exhaust and injen air intake are they easy to install or should it go to a shop?
Jack up your car, put it on some jack stands and check out the whole exhaust system. If there is a leak you will see carbon (black suit) where the leak usually is. Or you couls just take it into a trusted muffler shop and see what they can tell you. If your exhaust isnt rusted up to bad, repair should be pretty cheap.
 
1 - 11 of 11 Posts
Top