Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Just changed the water pump on my 1990 Stanza XE. The radiator is new. Changed that a few months ago. I have antifreeze leaking from under the car somewhere, so it seems. And if I drive for a few miles, the temperature gauge is not showing that it is running hot, but the overflow resovoir liguid is bubbling. What's going on? Please need some help. Thanks.
 

·
Registered
Joined
·
2,376 Posts
Weezie12 said:
Just changed the water pump on my 1990 Stanza XE. The radiator is new. Changed that a few months ago. I have antifreeze leaking from under the car somewhere, so it seems. And if I drive for a few miles, the temperature gauge is not showing that it is running hot, but the overflow resovoir liguid is bubbling. What's going on? Please need some help. Thanks.

is the resevoir bubbling hot or just bubbling?? possible that the resevoir leaks. What you can do, is get some coolant dye and wash your engine bay out underneath (very carefully i might add) and add the dye to the coolant and run for awhile, you might even put some paper under the car to see where its dropping at. Then with a blacklight you can follow the dye trail. If this isn't for you then you can try finding it without dye, or take it to a local shop to dye check it.
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
Check the radiator cap it doesn't seem to be holding pressure. I would probably replace it if it is even suspect.

Troy
 
1 - 3 of 3 Posts
Top