Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
I have a 99 sentra with kyb agx struts and ground control coil overs. Heres my problem.. since the day i have installed this setup im getting an odd sound when i make very sharp turns.. its almost like the top hats are not turning and its binding the springs causing them to make a weired sound. If i lube up the tops of the top hats where the bearings are it almost goes away completely for a few days but then comes right back. I have looked at the springs and they have not twisted around at all from the day i put them in. I'm really confused on what could be causing this sound? :confused: Any help would be great!! :)
 

·
Registered
Joined
·
177 Posts
Whats the duck tape trick? sounds kinda ghetto and i don't prefer ghetto riggs on my car lol
It's just wrapping the strut in duct tape so that the threaded sleeve doesn't move around, instead of using the rubber things that GC provides. The only other thing is to cut the spring perch off and bending the tabs so that the GC sleeve sits flat: http://www.sr20forum.com/technical-information-library/197942-how-cut-lower-spring-perch-ground-control-sleeves.html
 

·
Registered
Joined
·
62 Posts
Discussion Starter #5
Hmmm i like the cutting of the perch idea.. only problem there lies if for some odd reason [ and knowing my bad luck i would] needed to reinstall stock springs i would be screwed because of the missing perch =/ but its no biggie over time most of the sounds have gone away quite a bit.. or im eather just really used to it.. it could possibly be the ebay brand strut tower bars i have.. because the mounting plates on those things SUCK! the wholes are bigger than the bolts thus could be causing the mounts to slide around a bit makeing an annoying sound.. but as longs as no damage is being done wont bother me.. just crank up the radio and drown out the squeaking haha =]
 

·
Registered
Joined
·
41 Posts
Ha, Ha, ihave the same car with the same setup except i have stillen camber plates and tein solid mounts in the rear. the noise you hear is the springs binding up due to no lubrication in the top hat assy. use a real thick lube like wheel bearing grease and make sure you cover the entire strut upper bearing assy, you should be fine. you may have to do this every 2-3 months. i am a tech so it's not a big deal but it may be a pain the the a#$ for you. It won't damage anything. What else have you done to the car?
 
1 - 6 of 6 Posts
Top