Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys I have a 02 spec v that just threw 10 codes.
Emission system leak p0455
Internal control module p0605
Engine coolant temp sensor p0116 p0118
Fuel temp sensor p0183
Sensor power circuit p1229
Throttle pos sensor p0122
Throttle pos sensor switch p2135
Ctp learning p1225
Intake air sensor p0113
The day before my hid's just cut when it was raining. Popped my hood and the ballast and relay fuse were a bit damp. So I just threw my halogens back in and went home. Went to work the next day came home fixed the hids started up my car moved it over a parking space to adjust the level of the hid bulb took 5 mins at most hopped back in my car to run to the gas station and it wouldn't start. It cranks over and starts but dies immediately. Like I can't keep it started at all. Changed spark plugs checked all fuses checked relays. Does this sound like the ecu got fried or is there a way to have it get reflashed and would that work or what other things should I be looking at? It's driving me crazy just want to get it back running. And don't want to take it to nissan and get dicked around and pay out the ass. Any kind of advice or experience would be appreciated thank you!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Been looking can't seem to find a decently priced 5l non nats ECM. Prolly just bite my lip and get a new one and have the year warranty. Just need to get this car back on the road tired of driving the wife's civic hahaha
 

·
Sup Mod keeping the peace
Joined
·
6,254 Posts
With all those fault codes set, it sounds there may be a power supply problem since you mentioned a moisture situation around the fuses. Did the vehicle get flooded? If so, you may need to dry out several harness connectors on the EFI cable and connections to the ECM.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
@rogoman yeah I'm just going to take it to nissan tomorrow and have them check all the wires to make sure nothing is fried or shorting out first and in the mean time I'm looking for a used 5l or k3 ECM. If no luck just going to say fuck it and get a new one. I've checked all the grounds that I know of...I'm sure I missed one or two. Hahah but no car wasn't flooded. I removed the inner plastic inside the wheel well cause of how low I am I wanted more room without rubbing the plastic constantly and I'm guessing from that the water got up through there. Idk. It wasn't bad Just got damp. I'm hoping for the best, wish me luck! Hahaha
 
1 - 7 of 7 Posts
Top