Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Like two months ago i got my 2001 pathfinder se 5 spd 4wd. Then the first month, boom, the first o2 sensor (bank1 sensor2) gone. Ok, no big deal, it could happen to any car. I decide to do a tune up because of the mileage (145K kilometers) found out that the previous owner never did anything to her.

Now (last week) it was the second time the the check engine light came on with the codes for both rear o2 sensor lean...b/c i work on Subaru dealership i have tools and some books, but nothing for nissan, and the technicians at nissan don't like to talk, so thats another problem (one of them told me theres a bulletin for ECM reprograming for O2 parameters, True?)... so i need your help with a couple of things:

1. Whats the pressure for the fuel pump before the filter on idle and under accel

2. under medium accel when tach reaches 4000 rpm engine holds for a bit and then keep going till redline, but on hard accel, no problem, all good all the way

3. Sunroof doesn't open or close with the one touch function on the switch, only works little by little. Maybe the switch.

Thanks
 

·
Registered
Joined
·
430 Posts
Well your emissions should still be covered under the warrantee, I think it's a law to be covered for like 10 yearsor a certain mileage. They should do the ecu update for free. Since the previous person did nothing to the car, that might be a sticky point. Your sunroof problem is probably the switch and that shouldn't cost much to replace. You could probably do it yourself. The fuel pressure figures should be in a shop manual. You can order them from http://www.nissan-techinfo.com/nissan/
That's about all I can come up with, since I didn't do a search. Hope it helps.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Well, I took her to the dealership, pay for the full hour of diag and after 5 minutes they call me back at work telling me that the parameters on the air flow sensor are way off and I need to take 600 bucks more out of my wallet to fix the problem.....now well, 600 dolars after the part is on order and that mother f#@er part better fix the problem.

Ill let you guys now the result after......wish me luck :rolleyes:
 

·
Registered
Joined
·
5 Posts
On your sunroof... have you tried disconnecting and reconnecting the battery? I had the same issue with my sunroof a couple weeks ago and the battery thing worked.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
That's it, all fix, thanx guys, the sunroof is working like a charm and the truck itself it's running like never before with new air flow meter. By the way... the guys at Nissan told me to not use aftermarket air filter b/c that's the reason for the sensor to quit. The oem one comes with some kind of oil on it that traps all the dust, thing that doesn't happend with the aftermarket one. Good luck everybody and drive them hard...
 

·
Registered
Joined
·
90 Posts
I am glad to see some people talk out of their ass, first off Ecu is covered 8 years 80k miles, and as far as the sunroof the sunroof motor needs to be reprogrammed
 

·
Registered
Joined
·
5 Posts
titan_213 said:
I am glad to see some people talk out of their ass, first off Ecu is covered 8 years 80k miles, and as far as the sunroof the sunroof motor needs to be reprogrammed
Hey, all I know, or at least all "my ass" knows, is that the battery thing worked for my sunroof. (And I'm sure if I took it to a dealer that never would have been suggested.)
 
1 - 9 of 9 Posts
Top