Nissan Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
ok well for starters i have a 96 200sx. it has 190866 miles on this posting. the problem is very random, it hesitates and stumbles on/off acceleration. things i have changed include pre-cat o2sensor, fuel filter, air filter, brand new idle air conrol valve(those bsers got me for 120$), cap & rotor, spark plugs and wires, cleaned maf with spray, and it ran better but still had the problem. also note it happenned after i took it for a long run in the local public track if you know what i mean. i have also replaced my spark pllug tube seals beacause they were drowning the cylinders with oil. i need help, i have also been reading this post but it seems dead....http://www.nissanforums.com/b14-95-99-chassis/133233-stumbles-missfires-acceleration.html

sorry this is long winded but im trying to describe to the best of my ability.

ps it seems to be an ignition problem if thats helps
 

·
Registered
Joined
·
6 Posts
sounds like a distributor issue.unfortunatly it may have to get worse before it can be correctly diagnosed. if you get a camshaft sensor code a distrbutor will be required. Also sometines oil likes to leak into the distributor angle sensor wheel and can cause this. If there is an oil trail under the head\dist mating surface it will need a new dist. make sure you are using ngk spark plugs.

gtrmaster
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
problem solved it was the ditributor. the primary wire was extremely frayed, and it looks like oil was leaking from the valve cover, i replaced that a while ago, thanks gtrmaster ima post this in the other thread as well.
 

·
Registered
Joined
·
81 Posts
from what you showed in that video it looks ALOT like a MAF. cleaning it wont do anything actually using anything on a MAF sensor will damage it. i know most older nissans if u have the MAF unplugged it'll idle ok but die the second u hit the gas because the sensor isnt telling the computer more air is going into the engine causing it to not adjust injector P/W meaning lean itself out by flooding it with air. try and get it to act up and let someone tap the MAF sensor while it's acting up if that's what it is usually it'll clear up.
Most of the time when the idle drops like that when u let off the gas the throttle body is dirty, the MAF is funky or the IAC valve isnt working right. theyre expensive but i vote put a MAF sensor on it and see what happens
 

·
Registered
Joined
·
52 Posts
Discussion Starter #7
i replaced the iac expensive as hell, i cleaned the throttle body already and the rest of the intake for that matter, so i guess that leaves the maf sensor, that too cost the exact same amount as the iac valve haha. also the previous owner said he replaced it but when i took a lookie it was scribbled on there 96 nissan maf like how you write your name on tools with the tatoo looking thing so i guess that is the problem. well i just got laid off 2 weeks ago so money flow aint that good but i just barely got another job so hopefully in 1-2 weeks ill have enough. wish me luck
 

·
Registered
Joined
·
81 Posts
yeah if u see that or marker writing on it means they got a used one. that doesnt fix the problem just cuts miles off it. the MAF is the only thing i can think of u havent tried yet that can cause off-idle issues next to evap but that'd be consistant. MAFs arent until they go completely capoot
 

·
Sup Mod keeping the peace
Joined
·
7,253 Posts
Be careful about how you clean the MAF hot wire. Use only ELECTRICAL CONTACT CLEANER or a cleaner specifically made for MAF hot wire cleaning. This is the only thing you should use to clean your MAF. No windex, no carb cleaner, no brake cleaner, no rubbing alcohol, and no Q-Tips.

Other things to check:
- Check for major vacuum leaks in the intake system. Use a vacuum gauge.
- Check for a plugged up CAT.
- Check fuel pressure; it may be low. If so, the regulator may be bad or possibly the fuel pump.
- Do an ECU code readout to check for possible fault codes.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #10
yeah i used the maf sensor cleaner from autozone so it was designed for it....but today it drove perfeclty normal haha well any ways im still going to get a new maf sensor because apparently the last owner got it from a dismatlers or something. well i start my new job tommorrow so hopefully ill be in the pay cycle!!!!
 

·
Registered
Joined
·
52 Posts
Discussion Starter #13
lols i was just gonna update lols any ways i am a somewhat apprentice auto tech and when ii was doing a egr test on some v6 fwd acura i put vaccuum on the egr valve and it stumbled exactly like my car was doing i was surprised so im thinking it might do something with what controls the vaccuum to the egr valve like a vaccum solenoid gone wrong or something ima check the fsm right now so ill update in an hour
 

·
Registered
Joined
·
11 Posts
Also maybe a clogged cat? Good thing about this is you can replace it with a high flow and if that wasn't the problem then at least you're getting something out of it unlike swapping IACVs and such.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #15
true that was one of the first things i thought of but then my engine would die and beside when i floor it it opens up as usual with a clogged cat that wouldnt be possible unless a partially clogged cat but i would hold out if it was the cat because im saving up for the lower model tsi turbo kit, the one without the intercooler, because stock the cat is part of the header it doesnt just bolt up/off. any ways now im thinking about the egrc solenoid valve ima see how much this is. what do u guys think the fsm page is pg.428
 

·
Registered
Joined
·
52 Posts
Discussion Starter #16
another update well it sseems i am not having the problem anymore it just went away since i started my new 40 mile a day commute. then again i was use to a 1 mile commute lols any ways when i last updated i was basically gonna wait for it to act up again then pull the vaccuum hose off the solenoid to see if it was the egr system but it hasnt acted up for so long. my theory is that since i was coomuting for a mile the egr system or whatever the problem was started clogging up because it wasnt being used for long. cars are meant for the freeway anyways. well on to my next project getting the tsi turbo kit!!! im going to start another thread bout that today in the ga16 sub forums!
 

·
Registered
Joined
·
33 Posts
Hey guys!
I was following closely that thread. I have just solved my hesitation problem and figured Im going to share with you. In my case it was crank sensor and all I did was opening it up and spraying it with MAF cleaner ( all I had handy ).
It makes perfect sense to me now.
First I thought it was TPS, had it replaced with no effect, than MAF with no effect, than O2 sensor ( was trigering CEL ) and again nothing. Crank sensor has a rotor with 360 openings 1 degree apart. As distributor rotates opto-something sensor sends a signal to the computer every 1 deg of rotation. Now over time stuff gets dirty and openings may get clogged. That way computer gets lost in its counting and fails to make correct ignition and fuel injection timing. End of story...

Clean them distributors up before spending 200 plus on replacements guys!
 

·
Registered
Joined
·
52 Posts
Discussion Starter #18
update...well today at work i changed my oil really quick and all of a sudden it started hesitating again!!!!! although i was pissed i was kinda happy because the head technician was there when it was happening and he solved it in 24secs(not exagerating it was almost time to go and im always a clock watcher).!!!!you can imagine how pissed i was. any ways it was the maf sensor because apparently he tapped really hard on the maf sensor and the idle instantly went normal. wiggled it again and you can hear the maf sensor internals cracking sorta. so come next paycheck ima get a new maf sensor.

p.s. oh yeah jerry i was one of those guys who bought the new distributor with the cps built in that cost 2 freshly made 100$$$ bills and it helped a little but then every problem is different but thanks for sharing!
 
1 - 18 of 18 Posts
Top