Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 87 Pathfinder. Have had it about a year and love it. the person I bought it from abused it badly. The Engine and tranny run strong except for one problem that I can't figure out. When I warm it up after about a min the RPM will jump between 1500 and 2000 every couple seconds for about another min then it will level off at 2000 and go down slowly till it is about 1000 and completely warmed up. Sometimes it will do the same pulse thing when I get to work and let it idle in park for a little bit. I don't play in the mud or anything with it. about the only time I use the 4wd is when I need to pull someone out of a jam or it is snowy. Will be switching to manual hubs sooner or later. Also the person that I bought it from somehow snapped off the passanger front lower shock mount. How hard would it be to replace it. I am guessing I would have to replace the control arm?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
About 2000 miles ago. I know that it is about due. It still did that even after I did a tune up. What I mean by a tune up is plugs, wires, distributor cap, oil filter and oil change. I say that cause I asked at a few places around here and they all tell me that all they do for a tune up is oil filter and oil change.
 

·
Registered
Joined
·
307 Posts
Well, I've seen old injectors do things such as you describe. On that old of an engine though I wouldn't recommend getting them cleaned by an injector machine. Way of the beast I'd say. lol..
 
1 - 5 of 5 Posts
Top