Nissan Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
I just got my Maxima, and noticed that at night, the buttons on my auto climate control don't light up. Actually the 'Mode' and 'Fan' buttons on the bottom right side light up, but the rest don't. Is this normal?


Also, the digital screen is faded on the edges and I am considering replacing the climate control head unit. Is it easy to do? The left side fresh air lever is hard wired all the way back to the main vent. I don't want to mess anything up. What is the price for the head unit brand new?
 

· I've had more cars than U
Joined
·
686 Posts
I just got my Maxima, and noticed that at night, the buttons on my auto climate control don't light up. Actually the 'Mode' and 'Fan' buttons on the bottom right side light up, but the rest don't. Is this normal?


Also, the digital screen is faded on the edges and I am considering replacing the climate control head unit. Is it easy to do? The left side fresh air lever is hard wired all the way back to the main vent. I don't want to mess anything up. What is the price for the head unit brand new?
it's a normal problem.
you can remove the unit and replace a few bulbs which will hopefully fix your issues.
 

· Registered
Joined
·
75 Posts
Discussion Starter · #3 ·
OIC, so I won't need a new head unit, just new bulbs? Are the bulbs easy to find? Will the bulbs help the digital screen look better or is that different from the bulbs?

Also, when removing the unit, what is the best way to remove the fresh air vent cable attached to the lever on the far left side? I don't want to break anything!
 

· Registered
Joined
·
75 Posts
Discussion Starter · #7 ·
Okay, I went and bought the lights from the dealership ($6 each -ouch!). Took apart the dash - put them in - all the buttons light up and work great. The digital screen is another story. It is still dim - readable but dim. The weird thing is that if i give the heater control box is quick hit, it will sometimes light up light normal; nice and bright. Can you guess what connection is loose that is causing this and can it be fixed?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top