Nissan Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2001 Pathfinder and am having issues with my instrument panel (gas gauge, speedometer, tachometer, tempreature gauge, and digital mileage counter). From time to time the instrument panel and all the part listed above will cease to function. All needles will drop to zero and the digital mileage display will be blank or the digital reading be unreadable. It can stay like that for a while and eventually starts working again. Then breaks again. I also noticed that when the instrument panel goes out the miles are not accounted for, so who know how many more miles my car really has. I don't know what causes this and I am wondering if anyone out there has experienced such phenomenon? I appreciate any input anyone might have.
 

· Registered
Joined
·
197 Posts
Have you checked the fuses? Maybe one of them is loose. Worth a try.
Another possibility might be the panel connection but I don't know any details about it, maybe one of the experts on the forum can help you more.
Have you tried tapping or banging gently on the dash to see if it affects it? (when it's not working).
 

· Registered
Joined
·
79 Posts
Have you checked the fuses? Maybe one of them is loose. Worth a try.
Another possibility might be the panel connection but I don't know any details about it, maybe one of the experts on the forum can help you more.
Have you tried tapping or banging gently on the dash to see if it affects it? (when it's not working).
Also confirm that the ground for the gauge cluster is good.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top