Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 96 HB and my instrument panel and ac/heater lights went out. It happened when I hooked up a friends trailer to my truck. First, when I was testing the blinkers, it was very slow for the left signal and normal for the right.

For a little background....the previous owner had put a camper shell on the truck and put a switch in the cab that controls the light in the camper shell. He told me not to worry about it because it doesn't work:confused: I took the camper shell off so the wires for the light in the camper shell are disconnected now.

Back to my problem. So, when I was driving the trailer around the corner, I flipped the switch that the previous owner told me didn't work. My dash lights went out, but my blinkers worked fine. :confused::confused:

I figured I'd replace the lights in the instrument panel, which I did, but still nothing. Before I spen money on a new dimmer switch, I thought there was a fuse or something simple I'm overlooking <fingers crossed>
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
I Fixed it...somehow. I was going through all the fuses and the "tail lamp" fuse was blown. I replaced it and vuallah....I have dash lights.
 

·
Registered
Joined
·
1 Posts
Instrument Cluster Lights

I have a 1999 Nissan Altima and after a radio installation I lost my instrument lights and background illumination for the other stuff. After much searching I could not find anything wrong or a fuse dedicated to illumination.

It turned out to be the tail lamp fuse that was blown.

I replaced it and now everything works.
 
1 - 4 of 4 Posts
Top