Nissan Forum banner

Status
Not open for further replies.
81 - 100 of 103 Posts

·
Have I Hit 12's Yet?
Joined
·
5,326 Posts
NotAnotherHonda said:
youde be crazy not to, just because they look so damn good...i just ordered my 23.5x8x3 speaco FMIC...woohoooooooooooo...
unless your gonna go sleeper ( and even if you are, you should still get a bb or pulsar fmic for safety), i couldnt see why you woulnt want a fmic...besides to save a few dollars

i meant to say bb/pulsar top mount intercooler...not front mount...geez... :dumbass: (Me)
 

·
1.6 Turbo Power
Joined
·
718 Posts
Fittings List from ANPlumbing.com

Hey, just wanted to put the list of extra fittings that i needed to buy for the HS turbo install. they only supplied me w/ a oil feed and a few fittings, other than that i was on my own (well James helped me, but ya). anyways heres a list w/ prices and part numbers for you all to use. enjoy :thumbup:

Quantity - Part # - Part - Total Price
(1) - 981510 - Union Male AN to AN Adapter - 5.88
(1) - 992410 - AN Bulkhead Nut - 4.42
(1) - 178014 - Stat-O-Seals 2/pkg. - 6.97
(1) - 809110 - Swivel Seal 90 Deg. Tube Hose End - 25.46
(1) - 800110 - Swivel Seal Striaight Hose End - 9.95
(1) - 3000010 - Auto Flex Hose - 7.80
(10) - 790004 - 10ft. Blue Super Stock Hose - 25.50
(2) - 709145 - Super Stock 90 Deg. Hose End - 29.26
(1) - 816-4j - Straight Adapter Stainless Steel - 3.96
 

·
Boost anyone?
Joined
·
1,625 Posts
James said:
oops you're right... sorry did the write up at work and wasn't near my notes!

btw is the picture coming up? can someone host the picture on something more reliable than yahoo?
James, send me the pictures, i can host them on my site at www.teknoracing.com
 

·
NPM Lead Editor/Webmaster
Joined
·
4,571 Posts
Z_Spool said:

definately worth the time and money in my opinion. I want to put one on my dad's Sentra, but he want's to get a SR20DE and have XS engineering turbo it. they'll do a great job, (350 HP, at a reasonable "daily driver" level of boost) but it'll cost a grip of cash. Then again, $3,739.00 isn't a great price for 150+ HP IMO.
That was early...with stock maf... keep reading
 

·
Destroyer of Engines
Joined
·
561 Posts
Ok so I'm getting closer to doing my turbo install, hopefully the rest of my parts from HS will ship soon.

I had a few questions about the install and about the gaskets required.
Here is a list of gaskets I came up with that I thought would be needed for the install:
upper intake plenum to intake manifold gasket
Throttle body gasket(probably)
injector O rings
header gaskets
header to turbo gasket
turbo to dp gasket
dp to cat gasket
liquid gasket for oil pan

Did I miss any?

About step #17 on day 2 about where the wastegate line should be run, do you mean to the piping after the turbo and before the TB?

On step #18 on day 2(about the check valves), is this needed? This is the first I've heard of having to do this. If it is needed, where can these check-valves be bought and which lines require them (other than EGR)

Finally where is a good place to get vacuum line Ts in town, do regular auto parts stores sell these?

Oh and HS seems to be including coolant lines with the kit now, I think they are trying to make a more complete kit.
 

·
Destroyer of Engines
Joined
·
561 Posts
One other thing I wanted to ask. I was thinking of installing the injectors/MAF/ECU this weekend, how well does the car drive with this setup, without the turbo installed?
Also what should I set the timing at when the turbo isn't installed?
 

·
in^3,N20,RPM,PSI
Joined
·
4,652 Posts
Discussion Starter #88
Your gaskets, I don't know off the top of my head which one you need but that seems pretty complete.

The check valves, in the end I just disabled the egr. i kept getting no boost with the egr setup so I capped the vacuum line for the egr. You can get free check valves on the internet if you look in the right place, if not I used an aquariam check valve from a pet store... though not recomended...

Auto stores should sell t's and vacuum lines you need.

Man... HS is including the coolant lines NOW??? :rolleyes:

I would recomend you install the maf/injectors and ecu first and run for a day or two like that. Without the turbo is fine, it will drive just like a car without boost. Timing should be 10 with the jwt ecu. Debug all the problems first with the injectors/ecu/maf (if any) then put on the mechanical parts. it makes troubleshooting the turbo setup a lot easier.
 

·
1.6 Turbo Power
Joined
·
718 Posts
it was working before the turbo install, but unsure if it works now. just from physical test it seems like there isnt a problem with the valve itself. what could cause the tripping of this code?

another question, is using shielded wire for extending the o2 sensor wires neccessary?
 

·
Wise Cracker
Joined
·
5,730 Posts
AznVirus said:
it was working before the turbo install, but unsure if it works now. just from physical test it seems like there isnt a problem with the valve itself. what could cause the tripping of this code?

another question, is using shielded wire for extending the o2 sensor wires neccessary?
James is right $10 says it's a hose that has rotted out. Also which O2 sensor are you talking about? For the front one in the DP I did not have to extend mine. I simply un did the factory harness and re-routed the wire a bit back behind the manifold.
 

·
1.6 Turbo Power
Joined
·
718 Posts
wes said:
James is right $10 says it's a hose that has rotted out. Also which O2 sensor are you talking about? For the front one in the DP I did not have to extend mine. I simply un did the factory harness and re-routed the wire a bit back behind the manifold.
ya i should check all the hoses. im wondering if it has to do anything with using a 95 ecu... i just followed the instructions on the sr20dev site on using a 95 ecu on a 97+ car.

i extended the front o2 sensor wires cause the plug touched the turbo sometimes and burned it a bit and i had to extend the rear o2 wires as well.
 

·
Drifting is for amatures
Joined
·
1,578 Posts
Yeah that vaccum hose is a PITA.. its the one on the back of the egr valve.. its a small tube.. mine was like. litterally melted crap...i replaced it with a silicone hose.. i dont care how long it lasts.. its lasted me so far..
 
81 - 100 of 103 Posts
Status
Not open for further replies.
Top