Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
For the past month or so my car has had trouble idling it seems. My car runs fine until its time to slow the car down or come to a stop. When i bring my car to a stop, i feel the car start to shake pretty bad. And it sounds like it's trying to idle, but then it will rev up slightly and start the process again. I'm not sure if the clutch isn't disengaging or what but it doesn't sound or feel good.
 

·
Registered
Joined
·
391 Posts
This seems to be a common problem on this site, my car included! After cleaning out the IAC motor, timing check, grounded my air meter, it got alot better. But in the nd i adjusted my TPS and that really made the difference now it idle's steady and when you let off to slow down etc. it comes up to idle and stay's there with no jumping.
If you do a search it will tell you how to do all these thing's but i'd start with cleaning out the IAC and go from there.
 

·
Registered
Joined
·
391 Posts
Splice into the ground wire on the Mass Air Meter and TPS plug and ground it to the battery, that's what i did anyway's and it's worked fine so far!(6 months) I'll double check when i head down to the car but i'm sure it was a black wire, if you do a search i'm sure there's a post on how to do it and what wire it is! I also grounded the IAC, valve cover, head, etc. just for the heck of it probably pointless but my car seem's to idle perfect now! It could be a few things though mass air meter, TPS but i'd start with grounding the TPS and cleaning out your IAC motor on the side of your intake could be full of carbon.
 

·
Banned
Joined
·
4,308 Posts
1 - 5 of 5 Posts
Top