Nissan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
Just got a 30K service on my car, and ever since then, my idle has been weird. My idle in neutral jumped about 200rpms and is now steady at about 900rpms (which I don't mind because I'm going to be putting in ES MMIs anyway). My idle while in gear and with the clutch down is about 300rpms higher at about 1200. If I shift into gear from neutral, it will jump to 1200, and if I take it back out of gear, it will drop back down to 900 (all this while keeping the clutch down the whole time). Did the dealer just screw up my idle timing, or is there a more serious problem here?
 

·
Not Anymore.
Joined
·
5,014 Posts
if this is relating to anything, i would venture throttle body...i dont think it has to do with the maf. i could be wrong.
 

·
Registered
Joined
·
871 Posts
Your idle shound not varry with the clutch in vs. the clutch out. All the RPM ranges you state are fine, so it is up to you if you want to talk to the dealer about it. There is nothing wrong as far as I can tell.
 

·
Registered
Joined
·
12 Posts
I''ve recently encountered the same problem. My idle is at 1K at cold start...then remains there until I get into gear...thereafter it is almost at a constant 1.2K, sometimes it makes it down to 1.1K. What's even more strange though when I have push the clutch in after coming to a complete stop my idle hangs on at the 1.5K mark for a few seconds before coming back down to 1.2K again. Anyone have any idea what is wrong? I thought Injectors...tried various cleaners...no luck....air filter (stock) replaced...no luck...I thought maybe my oil was low or dirty...changed it and went synthetic...nope. I'm guessing I can try a full tune up. I guess I still need to check the MAF for debris or what not. I have unintentially drained my battery (by leaving on my headlights) so I guess the ECU was reset. What is the warranty for the SpecV? I'm reading 36K but I'm at 37,780 now...am I out of luck for warranty service?
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #5 ·
Update: I got a check engine light a couple of days ago. Took it in and they said the code was for an idle problem, and that my idle timing was off by 1 degree (something that they were supposed to check during my 30K mile service). Since it was their fault (probably a miscalibrated computer or something) they fixed it for free, now my car runs like a champ. Idle is approx. 700rpms now. If you're having the same problem that I was having, have them check out your idle timing.
 
1 - 5 of 5 Posts
Top