Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi, I just bought a 97 single cab with the 4cyl / 5 spd with 105,000 miles. It runs like a top! I noticed that when the truck is not running, there is a noise like a pump or something is running under the hood. I pinpointed it to the idle control valve part number E9T170 91. It runs for a few seconds, then stops, and continues the cycle. I've disconnected the electrical plug to shut it off, because I am scared it may run my battery down if it continues to do this night and day. Is this normal, or is the idle control valve bad?

Also, the air bag light is flashing on the dash constantly when the truck is running. Is there a way to reset this?

Thank you for the help.
 

·
Registered
Joined
·
41 Posts
Hi, I just bought a 97 single cab with the 4cyl / 5 spd with 105,000 miles. It runs like a top! I noticed that when the truck is not running, there is a noise like a pump or something is running under the hood. I pinpointed it to the idle control valve part number E9T170 91. It runs for a few seconds, then stops, and continues the cycle. I've disconnected the electrical plug to shut it off, because I am scared it may run my battery down if it continues to do this night and day. Is this normal, or is the idle control valve bad?

Also, the air bag light is flashing on the dash constantly when the truck is running. Is there a way to reset this?

Thank you for the help.
Check the spiral cable. Replace the vavle.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
will the truck run ok for a day or so until i can get a new valve? Do I have to get the valve from Nissan, or will an auto parts store have one?
 
1 - 3 of 3 Posts
Top