Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First off its a 1984 300zx turbo, Bone stock. When the engine is cold and hasnt run all night it runs great! But it Has a problem when its ran for a bit and is warm that it Bogs out and sputters really bad off the line, and basically inches till it gets goin then a huge burst off speed. Once its goin it runs fine, No problems what so ever. But from a dead stand still i can put my foot to the floor and itll sputter its way to till it takes off all of a sudden. I can smell that its running rich, So could it be that its flooding itself out ? Someone also told me my catalytic converter could be bad. Any help would be greatly apprectiated. i love my lil dotty!! Thanks
 

·
Registered
Joined
·
2 Posts
hope this helps

you can check to see if there is a restriction by pulling the o2 sensor right after the turbo and checking backpressure, i think it should be around 1.5 psi at an idol, other symptoms of clogged cat are bad fuel milage, excessive engin temp and lack of power at high speeds. you can check to see if the cat is operating properly by checking temperature between the front and back of the cat, i think for older model vehicles it could be around 150 deg hotter at exhaust side. any more than that you could have other issues.

as for your problem, possably check the tps for linearity, disconnect the sensor and with an ohm meter measure from ground side to refrence while slowly increasing throtle.

let me know if this helps
 
1 - 3 of 3 Posts
Top