Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
This is my first post on this site I'm a new nissan convert... I believe I'm having problems with my hot wire modulator.. Do I need to replace the whole maf or is there an easier way to fix my problem? It wont rev past 2500 rpm and it's real jumpy at me. Please help!!!!
 

·
Registered
Joined
·
3,344 Posts
if it wont rev past 2500 your in "fail safe" mode, are you sure its the hot wire mod.? What year, engine etc ??
try to pull some codes to make sure before you spend $$
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It's a 1996 made in april with the ka24. I'm starting to think that the ground could be bad or something. Sometimes it will work correctly and sometimes it lets me wrap the motor out. Sometimes it starts geting jumpy and trying to limit engine revs around 1500 it just varies. Most of the time it just tries to cut out at 2500 and in 5th gear (5m) that works out to 50 mph. Is it common for the maf to be bad around 80000 miles?
 

·
Registered
Joined
·
117 Posts
is the maf loose? causeing it to give fails readings or a short?
 

·
Registered
Joined
·
206 Posts
MAF sensors don't have to be "bad" to be a problem. They could just be dirty. You can take it off and visually inspect it and if it looks dirty/oiley you can clean it with some electronics cleaner and a Q-tip. Just be careful...they're pretty fragile.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Ok I should mention that I live in alaska so it gets kinda cold here. This morning when the truck was cold it ran fine with none of the problems it has been having. Once it warmed up the truck started bucking the fuel was cut off till engine speed dropped to 2500 rpm. I'm going to get some contact cleaner and clean the maf tomorrow when I get off work. Will rubbing alchohal work or will that be harmful?
 

·
Registered
Joined
·
706 Posts
Ok I should mention that I live in alaska so it gets kinda cold here. This morning when the truck was cold it ran fine with none of the problems it has been having. Once it warmed up the truck started bucking the fuel was cut off till engine speed dropped to 2500 rpm. I'm going to get some contact cleaner and clean the maf tomorrow when I get off work. Will rubbing alchohal work or will that be harmful?
Sounds like a bad EGR valve! It's leaking!
 

·
Registered
Joined
·
206 Posts
Ok I should mention that I live in alaska so it gets kinda cold here. This morning when the truck was cold it ran fine with none of the problems it has been having. Once it warmed up the truck started bucking the fuel was cut off till engine speed dropped to 2500 rpm. I'm going to get some contact cleaner and clean the maf tomorrow when I get off work. Will rubbing alchohal work or will that be harmful?
Rubbing alcohol is fine. Sprays are better if you want to avoid physically touching the sensor with something but if you're gentle, alcohol and a Q-Tip should work.
 
1 - 10 of 10 Posts
Top