Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi, i have a 1994 sentra xe 1.6L. Just out of the blue it started idling and stuttering VERY badly during low rpm. It hesitates a lot under quick acceleration as well. I immediately replaced the fuel filter, checked the spark plugs, checked the o2 sensor..all of the sensors are connected and seem to be functioning. No dice. Has the same problems.


The first day of this, it was producing a bad rotten egg smell. So i figured it was the cat converter. I replaced it with a brand new one. STILL same problems. Actually, after replacing the cat, the smell became WORSE, and instead of a rotten egg smell, it was some horrible chemical smell i cant even describe. Definitely not that of a new cat.

After test driving it for a little bit i returned home, and saw some smoke rising up from the rear engine area. I couldn't pin point where it was coming from except that it was behind the engine. I dont think its bad gas as ive filled it with new gas. PLEASE help me! Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
ok..well i think i may have found the problem...one of the cylinders is flooded with water/coolant. im gonna do a compression test and see wut happens.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
did a compression test and it passed. the cylinder that was flooded actually had the highest compression at 150...still the same problems
 

·
Registered
Joined
·
1,014 Posts
Did you do a leakdown test. remove the radiator cap when doing this. it will come out of the exhaust pipe, intake or the coolant will bubble. you hand turn the crank pully to open and close the valves. you can do this to help diagnose a problem. take it to a professional to evaluate.

The coolant in the cylinder is the head gasket blown. Or the block cracked and is letting water into the cylinder from the water jacket.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
yeah, thanks for the reply..i dont understand how it would be a blown gasket or crack tho, as the compression was fine. I am all out of ideas.
 
1 - 7 of 7 Posts
Top