Nissan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
alright i still have my two injector problem..... this sucks alright my two middle injectors dont work theyve been cleaned and they have voltage. i cleaned all the injectors swapped plugs changed fuel pump and most fuel lines and fuel filter. checked alot of vaccum lines put in another distributor because i thought it was the crank angle sensor. i put in a new computer and still nothing the car wont idle . heres a pic of which injectors are working

W-N-N-W

w=working and n=not working.


the car was being run on bad gas but we drained the tank and nothing seems to be clogged i just dont get it nor my mechanic plz help!
 

·
Registered
Joined
·
4,219 Posts
change the inner injectors to the outer positons to help diagnose the problem
 

·
Registered
Joined
·
74 Posts
Discussion Starter #6
actually when we cleaned them we dont know what order the got put back in but we bench tesdted them all and they all opened and sprayed.
 

·
Registered
Joined
·
4,219 Posts
so can you put a meter on the harness and check the signal while its running, assuming its not the injectors then its the harness or ECU.
Are you sure its not the spark ??
 

·
Registered
Joined
·
74 Posts
Discussion Starter #8
after all iv done im pretty sure somehow the timing got messed up can anyone tell me the correct way to set the timing chain?
 

·
Registered
Joined
·
4,219 Posts
first download the FSM at phatg20.net
if the timing is messe dup the ignition timing will also be messed up.
 

·
Wise Cracker
Joined
·
5,730 Posts
after all iv done im pretty sure somehow the timing got messed up can anyone tell me the correct way to set the timing chain?
YOU cannot mess up the timing chain unless you opened the motor and messed with it or it skipped teeth which is very uncommon. I am assuming you are just talking about the timing being messed up, in which case that is a simple fix.

You should download the FSM from the recommended site and use it to solve your problems. Get the timing set correctly and then see if the injector issue still exists.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #11
my mechanic thinks it skipped teeth but i dont really see how it could happen but the marks on the sprockets are all pointing diff ways
 

·
Registered
Joined
·
4,219 Posts
you will have to rotate the crank up to two revolutions before the marks line up.
As Was says its unlikely that its skipped a tooth, download the FSM and take a look.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #13
ok well there is no 93 on phatg20 but they have 94 does that work? but the thing is i have dial up!! it will take all day can someone just tell me what to do!? if you can tell me how to make the marks line up then will i need to do ignition timing too?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #14
we got the timing right but then we put air down each cylinder and while they were closed air was coming out of the other cylinders so he thinks the head is cracked or the head gasket blew or something to do with the valves what do you guys think
 

·
Registered
Joined
·
4,219 Posts
then do a compression check on all 4 cylinders
this will tell you for sure, did he do a proper leak down check ? I don't understand what he did
Reading should be 165 -195 from memory
 

·
Registered
Joined
·
4,219 Posts
Then most likely is a blown head gasket and head may be damaged / warped.
Timje to decide on either a repair or a low mileage replacement.If you are doing the work you could lift off the head and see how bad it is. before spending any money.
Someone quoted $300 for a re-built head, i think you could get an engine for not much more than that.
 

·
Registered
Joined
·
4,219 Posts
sorry about typo
 
1 - 19 of 19 Posts
Top