Nissan Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

I am having a problem with my turn signals. They don't work and I don't know why. Fuses are good. I have tried a new/different (used) switch and the hazard lights work fine. Any suggestions? Thanks.
 

· Biru O' Kudasai
Joined
·
1,434 Posts
Is the flasher unit bad? Check in the owners manual for the location to replace it. I don't remember off hand but it may be a combination flasher unit with the hazards. Since the fuses are good and the hazards work fine with the bulbs also being good that pretty much isolates it to the flasher unit.

Troy
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 · (Edited)
got it

KA24Tech said:
Is the flasher unit bad? Check in the owners manual for the location to replace it. I don't remember off hand but it may be a combination flasher unit with the hazards. Since the fuses are good and the hazards work fine with the bulbs also being good that pretty much isolates it to the flasher unit.

Troy
Got it thanks anyway. The flasher is a combo unit. I had orginally checked the turn signal fuse with a test light and the fuse checked good;however, the terminal the fuse plugs into (inside the fuse box) was streched open too far not making a good connection.

****Now the turn signals blink fast and the only ones that work are the rear and the front on the bottom. The front side don't blink however they come on as park lights and they are single filiment bulbs. Are they supposed to blink? Any ideas? This car has some odd problems. I just got it a short time ago and all these problems were inherited.

Thanks.

All done. Both front lights had bad grounds/corrosion in the sockets.
 

· Biru O' Kudasai
Joined
·
1,434 Posts
Glad you got it fixed. When you said they were blinking fast I was going to suggest checking the ground(s) on the front but you found it. Good Job!

Troy
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top