Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey Guys i cleaned my throttle body, and now i'm getting P0507 which is high RPM's and when in Park i'm running 900-1000 which isn't normal. I also get a hop each time i'm at a complete stop near 1000 RPM's then jumps 100/200 RPM's and drops suddenly to 900-700 when i'm completly stopped. I believe i may have ruined the timeing, but i'm deciding if i should just replace the throttle valve and get it reprogrammed by the Nissan dealer to save me the trouble, or attempt to clean it again and take it to the dealership to reprogram it. please check video to see if the valve is acting as it should.

This is me during the Valve close sequence by turning on and off the ignition.

YouTube - 02 Nissan Maxima Throttle body problems
 

·
Nissan Technician
Joined
·
826 Posts
Something you need to know about those electronic throttle bodies...NEVER EVER push on the throttle plate with your fingers, even to clean it!
We've damaged and had to replace PLENTY of these at the dealership cause we would clean them and had the same problems as you are having!

Basically, you shouldn't clean them!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Metro,

Alright a Chicago native coming to the rescue! I'm from Chicago, but currently in Austin, and will be heading down to Chicago next week. I've heard that this is a sensitive process, and its some what of a 50/50 chance. Does the symptoms i explained with the hop each time i stop sound like the throttle body is out of sync? i've tried the relearn process a few times, but no difference:(. Do you think i could save the throttle body and hash over the 96 bucks to try and get it relearned? I REALLY appreciate the help!

Edgar
 
1 - 3 of 3 Posts
Top