Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My E16i is just not running well. It is the worst when the engine is cold or if I'm going up a hill. Since I bought it about a year ago, I've replaced the plugs, wires, rotor, cap, and fuel filter. I've also run the best injector cleaner thru it that I can find. What's really strange is that on a level road, it seems to run well under WOT. Any suggestions?
 

·
Still moderating..sorta
Joined
·
1,324 Posts
Check your timing, and your fuel pressure regulator
 

·
Banned
Joined
·
107 Posts
Ya check yur timing! I have experience in that department there...TRUST ME!! Its very simple for me bein 14 and all so it shouldnt be hard for you unless yur completly clueless on what yur doin. but if ya ask me, you better get a friend to help ya if you are goin to DIY. It shouldnt take no more than a day unless you have certain delays like i did (bent valves!). The E16i is 2 times simpler to work on than any old GA series. So if like the timin was right and it suddenly skipped a notch then you better get it replaced or you will know what will happen! 250 to 300 bucks it cost me!
 

·
Banned
Joined
·
1,254 Posts
Correct me if i'm wrong, but if his timing belt jumped even one notch which is roughly what, 10-12 degrees, his motor will run like crap anytime, and prolly have a bent valve.

I'm gonna go ahead and bite the bullet and say you may have uneven or low cylinder compression. Other than that, since it's having issues going uphill or when it's cold, the ignition coil or power transistor is weak or going out. You could just be detonating like hell, run premium for a while and see if that helps. Can you tell if it's running too rich or too lean??
 

·
Registered
Joined
·
29 Posts
Check your timing and have a leakdown test done on the engne, that should tell you if your losing compression and where(piston rings, head gasket, crackedblock etc.) also, for an initial test, get a vacum gauge, pull the spark plugs, and have a friend turn the key, write down the compression and check it against standard. hope i'm of some help
 

·
Registered
Joined
·
2,376 Posts
SuperSentra4203 said:
Correct me if i'm wrong, but if his timing belt jumped even one notch which is roughly what, 10-12 degrees, his motor will run like crap anytime, and prolly have a bent valve.

I'm gonna go ahead and bite the bullet and say you may have uneven or low cylinder compression. Other than that, since it's having issues going uphill or when it's cold, the ignition coil or power transistor is weak or going out. You could just be detonating like hell, run premium for a while and see if that helps. Can you tell if it's running too rich or too lean??
actually most cars once notch wont bend valves. I've never looked deeply at the e16 so dont know if it would or not...i've never heard of bent valves in an e16 either, would have to have cam off by alot to do that
 
1 - 7 of 7 Posts
Top